Problems with NodeMCU v3 + WS2812B + levelshifter

I’ve created a simple circuit on perfboard for my 5 meter long WS2812b (60 leds/m) led strip and I keep running into weird issues. Here is a picture of my setup:


Note that I’ve soldered everything on a perfboard (and used wires with the right wire gauge) but I used a breadboard in Fritzing to display my configuration. :slight_smile:

Initially the LED-strip worked fine but after a couple times unplugging it, it became unreliable: the NodeMCU V3 doesn’t connect to my Wi-Fi network, doesn’t save changed settings and doesn’t create a AP while my router doesn’t show it’s connected to my network. Flashing it again doesn’t solve it. When it works, it works great.

Can someone confirm that my wiring is OK? If my wiring is OK then I know that the NodeMCU has to be the cause and I’ll have to order a new one.

Parts used:

  • Power supply: Mean well LRS-50-5
  • Level shifter: 74AHCT125
  • Board: NodeMCU V3
  • LED-strip: WS2812b (30 LEDs per meter, 150 LEDs in total)

EDIT: final setup in this comment.

I can’t add more than two links because I’m a new user so here the links for the board and LED-strip:

PINs 1, 4, 10, 13 have to be grounded. Remove resistor for testing. After you can replace with 56 Ohm. What bin file did you use?

I can’t fully see it but I believe you have a ground issue.

I’m not sure which pins you are talking about but I am fairly sure you mean the pins of the NodeMCU, am I right? I don’t think you mean the GPIO pins because that includes the TX pin. Could you explain which pins exactly I have to ground?

I flashed version 0.11.0 of WLED, binary WLED_0.11.0_ESP8266.bin, and I used ESP Home Flasher.

@Thedannymullen If you need more information to be sure please let me know! :slight_smile:

I meant shifter not a NodeMCU.

This is the level shifter. Data sheet says what to do for unused input as.

I’m sorry, that seems to make a lot more sense now you say that.

I just connected those pins to ground and I removed the resistor. Everything seems to be working just fine. The thing is that the LED-strip already worked fine before and there didn’t seem to be anything wrong with the dataline. If the NodeMCU booted and connected to my Wi-Fi network succesfully everything worked fine.

The problems I experienced (not connecting to the network, not setting up a AP, not saving settings) seem to be related to the NodeMCU. Or is it possible that not properly connecting the grounds could have caused this? Unitll now I’m not experiencing any issues but it’s hard to test since these problems seemed to be occuring randomly. I’ll monitor it the next couple of days and I’ll report back!

Maybe a stupid question but these issues can’t be caused by shutting down everything by just unplugging the power cord, right? I assumed that this wouldn’t damage the NodeMCU and I can’t find an option to gracefully shutdown WLED but maybe I’m missing something.

I’m glad you have working controller now. Grounding is very important in any circuits. It’s a good practice to study first data sheets and any related documentation. Good luck with building more nice stuff.
Oh and it’s fine to unplug power from controller. There’s nothing to shutdown like a computer.

@srg74 The controller already worked before. :wink: The problem was that it was unreliable: the problems I described occurred randomly, sometimes within hours, sometimes within days. I’ll monitor it and I’ll report back in a couple of days.

For now I have confirmation that my circuit is OK and if I experience any problems I’ll know that the cause is most likely the NodeMCU. Thanks for the help!

After a couple days of testing I’m still experiencing the issues I mentioned before. I’m now 99% sure that the NodeMCU is defective so I’ll replace it. Thanks for all your help @srg74 @Thedannymullen!

For anyone interested, this is my final setup:


Again: I only used a breadboard because I find it easier to display my setup. Do not use a breadboard for such high currents!

1 Like

Remove resistor

@srg74 I already tried that for the first couple of days and that didn’t make a difference. And the resistor doesn’t influence the basic functions of the NodeMCU, right? As far I’m aware it only protects the levelshifter for current surges and shouldn’t affect the NodeMCU. I’m not experiencing any problems with the dataline.

On your diagram resistor is 330Ohm it’s at least to much for a setup. If you want to use one it should be 56 to 62Ohm. New strips is different than strips few years ago.

Its your power supply. It only outputs 10 amps.

If you push a 5 meter strip to its full brightness its going to draw +/- 18 amps. Having 10 amps only available, that will cause a brown out condition. And the brown out effects the esp as well, causing problems.

Hope its of help.

1 Like

I haven’t exactly described which LED-strips I use so I’m sorry for the confusion. I use a LED strip with 30 LEDs per meter so 150 LEDs in total. I’ve calculated that it will draw 9 Amps at max (150 * 0,06A) and the seller rates the strip at 9 watt per meter so I think I’m safe with a 10A power supply. :wink: Thanks your help though!

@srg74 I’m not experiencing any problems with this resistor. Could you explain why you think a 330 Ohm resistor is too high? I see a lot of people recommending resistors with different values but I can’t find an explanation why the one value is better than the other.

Try running with 75 pixels for some time, to see if the esp develops problems.

10 amps is still tight for 150 pixels. I like to add 20-30% more amps then needed for my projects.

Hope its of help.

It’s calculated by experience.

Thanks, I didn’t think of that. I’ll test the strip for a couple of days with 75 LEDs turned on.

@srg74 Unfortunate that you don’t seem to be willing to substantiate why you have given this advice. Too bad it hasn’t made any difference: I’ve tested it for a couple of days and I still experience problems. Thanks for the effort though.

What I don’t want to substantiate? Can you explain in details what explanation and evidence you need.