Flickering issue on long run

I’ve had no issues in the past with smaller setups.
This year I grabbed 300 pixels and put them inline and I’m experiencing a slight technical difficulty.

The controller is a few inches from the pixels.
I have 12V coming in to the lights, 12V being bucked to 5V into an esp device(it is rated for 5V).
From there I have a level shifter pushing the output from the ESP to 5V.

I have three runs of 100 lights. End to end.

I’m thinking that what I have is some sort of power issue but I’m. It sure what it is.

I have a power supply rated for plenty of power, in fact two of the same and swapping them out does make a little difference but doesn’t make the problem go away.

The power supply is 10 feet from the controller and injecting power 10 feet out and 15 feet out. I.e. it is in the middle of the string.

I tried a few things, like popping off the 3rd strand at the end and it didn’t fix the problem. This leads me to think there isn’t a problem with enough power, and the LEDs can go nicely white from end to end.

Is this something that’s just dirty power? Is it a problem with the strands?

Hope this link works.

I also tried pulling the data connection off the last strand and kept power on and the lights stayed lit and still had the flickering problem.

Any thoughts? Is it grounding is it a flaky PSU? Should I out a capacitor on the PSU? Replace it?

It wouldn’t hurt to make sure all the grounds are bonded.

I made sure all the grounds are bonded.
I built a fresh controller, the original was with a NodeMCU, this one is with one of the tiny little ESP8266 units with 8 pins. The same problem exists.

I experimented by pulling the controller off the line and the problem stops, i.e. the lights stay lit properly and constantly. There seems to be some sort of power problem, but I can’t for the life of me figure out where.

There’s enough juice to keep the lights lit, so it isn’t a question of amperage, the problem even occurs when the leds are significantly dimmed.

You can see the layout of the board, I’m pretty sure everything is good, but I see some people put resistors inline with the dataline, not sure if I should be doing that or not in this case.

My question is, is it possible that the PSU being so far from the controller could be a problem?

Would adding a capacitor to the power line help?

Here’s the layout of the power.

what is that 3v regulator? You should be supplying 5v to the esp, not 3v. Looks like a data issue to me. Ground issues normally make the LEDs do the disco.

Disco might be preferable at this point.
The esp is a tiny module it has no 5v control.
I had a nodemcu and was feeding it with the 5v had the same problem.

I am now thinking the problem is that I don’t have any filters around the 7805.

For the most part it hasn’t been a problem the way it is wired.
The same setup works just fine for a much smaller run of LEDs.
This is my first time using a booster on the signal and it seems I’m doing it wrong.

what level shifter are you using?

Amazon special.
KeeYees 10pcs 4 Channels IIC I2C Logic Level Converter Bi-Directional Module 3.3V to 5V Shifter for Arduino (Pack of 10) https://a.co/d/7mNTzI6

Anything that says I2C is usually too slow. Same for ones with transistors like that one.

Check KB for suggested parts.

1 Like

Where’s the KB live?


Thanks all. I moved forward and got a 74AHCT125 I’m not convinced I have the wiring correct. I added it to circuit to replace the existing level shifter and it did not go well.
I’m not sure of the wiring for the level shifter, looking for some advice on whether or not I’ve got this sucker done properly.

That diagram looks good except for the classic “gotcha” → unused inputs (2A,~2OE, 3A,~3OE, 4A,~4OE in your diagram) should be tied to GND or +5.
They should not be left “floating” or they’ll likely pickup noise and cause grief.

You also need a ceramic Cap not the electrolytic in your pic.

Lots of good advice.
I grounded all the inputs that didn’t solve the problem. I’m getting like random signal.
I’ll wait until I can get a ceramic cap and see but I suspect I’m doing something rather wrong.
This weekend I’m going to restart from scratch and see what happens

Non-ceramic cap is rather wrong. :wink: