Issue with Editor for Mapping

I set up a router for the wled. I can access the wled interface at (fixed IP). I can control my lighting and all the settings. However, when I access the mapping editing page using the address:, it shows a blank page. The title on my browser says ESP editor. I even tried different browsers, including Firefox, Edge, Google Chrome. I just can’t see the ledmap.json button. I am also using ESP32 with wled latest firmware v0.13.0-b6"Toki".

How do I fix this so that I an edit the ledmap.json file? Is there any other way to update the ledmap.json file?

Thank-you in advance.

How did you flash that ESP32?
It shows a FS of only 983kB which is a little small and possibly suspect.
You might try a full manual reflash using w/Chrome.

Your router/network setup should be fine and if you can reach the WLED GUI at all, shouldn’t be an issue.

983k is correct and expected.

@wdigi ledmap.json does not exist by default. you have to create it.

Is that correct for a new ESP32 flash?
All mine show as 1507kB.

I can see carrying forward an older (smaller) FS flash, but I’ve had issues in the past where corrupted FS has caused grief.

I got the impression from the OP that there were no options on the /edit page, but if it’s just a missing ledmap.json (everything else shows up), then you’re correct (of course) just needs to be created.

You may soon be unable to do OTA.
With b6 partition scheme changed.


I remember reading change notes on that, but I mistakenly thought 1507kB was the new “std”.

Better have a look at my installs…

I did the installation on wled’s web interface installation page.

How do I create ledmap.json? The editor page is blank. I can’t see the create ledmap.json button.

I found a solution and got it working now.

1, tried directly connecting to ESP32 AP, edit page was still blank.
2, Setup the ESP32 wled controller to another router with dynamic IP, the edit page is working! I can see the tool bar and buttons.

Not sure why the other router doesn’t work. Why directly connected to the ESP32 wifi and the edit page is blank. Is it something to do with fixed IP?

your client has to have internet access to load edit pages

Yes! That’s it! I guess it is because of some CSS bootstrap need internet connection to load. This is not ideal as not all lighting systems have internet connection.

You have the upload capabilities for most files. /edit is needed only for advanced things.
ledmap being one of them, but usually those installs have wifi connection.

I guess if the user guide mentions about the Internet connection needed to load the CSS and/or JavaScript, it would have saved me hours of troubleshooting. Having said that, wled project is a great project. I was actually looking for commercial support.

I was working on a new site where Internet connection isn’t easily accessible. There are also lots of applications where users access the wled edit page directly through ESP32 wifi ap at without the wled controller connecting to the internet. In this cases, the edit page is also blank.

You can add this information to WLED docs and contribute to the project.