WLED Not Controlling Lights

Hi All

I have been trying to get my LEDs setup with a WLED and a D1 mini. My lights power on but they don’t respond to the controller. I have tried different boards and different lights but no luck. Is this some setting I have wrong? The lights light up with a yellow blue white and red random rainbow pattern. I tried to adjust the gpio pin but nothing. Any ideas?


Do you have both ground and data going from the D1 mini to the LEDs?
Does the D1 have a levelshifter on board?

1 Like

I have tried powering the lights both through the D1 and directly from a power source, same result. When I plug in/out the wire from the D1, there’s no response on the lights at all.

How would i know if i have a level shifter?

I’ve also tried this on a Node MCU, and an ESP32 but same result. It has to be some kind of setting i have wrong right?

Have you configured WLED for the different GPIO pins you’ve been trying?
You go to Config->LED Preferences->Hardware Setup and set the GPIO pin # to the same one your using to connect your LEDs.

Yep. I’m set to GPIO2 on the WLED UI. and the wire is attached to D4 on the d1 mini and i tried d4 on the node mcu also.

This is what it looks like when plugge din.

it should just be a solid pale yellow, right?

It looks like you’re trying to power your entire strip via a USB connection.
That’s not going to work, USB won’t be able to supply enough power for more than 30 LEDs (at best).
Try using a separate dedicated 5V supply for the LEDs.
Can’t see the top side of your ESP32 to know for sure, but I’d guess you don’t have a levelshifter on board so you may need one.
Additionally make sure you’re feeding your data to the Data In side of the strip, there is a direction for data flow.

I thought about the power. Now they are directly plugged into a power supply. This is the one i’m using.

I took a pick of the board. Any ideas?

Pretty standard ESP32 board, no levelshifter on board.
Are your LEDs 12V? Do you have any specs?

Make sure you’ve got the data direction right.

Ok. it’s definitely in the DIN. it could be the power supply. I think i may have used the wrong voltage. i’m ordering a 5v. let me try that. thanks for the help.

If you powered 5v LEDs from a 12v power supply you likely killed 1, some, or all of the strip. More likely you just killed the first LED. I would cut that one off and try from the 2nd one. Or if you don’t want to cut it off try just scraping the coating off the Data solder pad that is before the 2nd LED and pressing your data lead to it to see if you get anything to happen.

Doesn’t bode well, a brief (less than 5 seconds) connection to 12V for a 5 strip will definitely kill some of the first LEDs, longer will kill more or all of the strip. You’ll probably have to cut the strip in 1/2’s or more to test. My experience has been (when I’ve made that power supply mistake myself) that some of the damaged LEDs will jam up the input of the following (hopefully) good LED so you can’t tell without disconnecting the previous output.

Sad to say you’ll likely have to write off that strip to experience.
“Experience is the thing you get just after you need it…” :face_with_diagonal_mouth: