ESP32 s3 cant!

Oh boy…
Hi everyone.

I have these…
Apparently esp32 s3 8 and 16 mb
I have 2 of each type.
Neither want to play at all… failing …

Confused with finding many attempts at getting some life out of them… yet haven’t found the one that helps.

And i appreciate it’s experimental the binaries for this chip.

Only bought these as i was running out of ram from amount of leds and use.

Need help… either on this problem or a direct link to the esp that will do the task… remembering my memory issue.

Please dont just send gpt inspired replies i read them all… trust me.

Trying to move forward but keep gitting these snags

Thanks … theres a wealth of knowledge here… only need a little of it lol…


You can use PlatformIO and flash these successfully. You will want to choose OPI variant from build environment.

Thanks for a prompt reply.

Thats the kinda reply that i like.

Im assuming that for the 16mb and not the 8.?
Is there one for the 8mb variation ?

I even tried to create a bat file to do what I read somewhere…

Also …
What to use to successfully flash this opi variant please?

One if the online?

Is there a boot flash like the standard esp32 ?

Is there no preparation for this chip beyond flashing this?


Oh AND ONE MoRE thing lol…

This has two type C ports on it …

Which one should be used if theres a difference…

There are boards with 4M, 8M and 16M bytes of flash and boards with zero, 4M, 8M and 16M of PSRAM.
WLED has an environment fo 4M and 8M flash sizes. If you have different size you’ll need to select correct partition map from the tools folder.

Although i have gotten used to using visual basic code… and have peeked into its innards… im still none the wiser…lol.

Have altered the odd line. And have seen the benefits of using overide ini…

My knowledge as i wonder round these Wled corridors is to gather specific examples from which i can learn.

I underplay my abilities purposely njst so you dont bombard me with stuff thats on a blackboard at NASA !!

If you could explain how to acheive the use of those tools folder parameters i would be most gracious.

Ive clearly yet to set MY environment up… but with your patience & understanding i will gef there.


Hello again.

I was having no succes flashing that particular file. Using cli. The same way worked for my other esp32.

So idle hands led Ardiino ide…

I have no clue how this works but ive got a gist from past video… like a visual code?

Anywhoo poked and prodded. And found get board info…
I will assume thatbwoll work anytime once board plugged in… either with boot held down or not.

The get board id returned the same thing for both

So i havent a s3…its c3 …first surprise.

It dont look very mini…

Ao is this the boards thats meant to be most compatible? And now its shown up as that… will it actually work now if i use c3 binaries?

I started with
Oh boy…lol

No it’s an S3. The Board info thing is almost always wrong, completely useless since it looks at IDs that are shared by many things.

Alas you are correct lol

When i tried to use the installer that said different.

2 days … hours in… loosing grip on realities…ash tray over spilling… and i dont even smoke !! Lol

Could get these things to play ball.

I did try the suggested version visual studio code and compoled it many many times… yet that didnt get a working install…

So treading where i thought would be a anti productive. I tried to flash the esp32 s3 4mb.

Low and behold … it worked… on both 16 and 8mb boards.


After all that i dont think im in a different position than using normal esp32 4mb. Will steill get memlry issues?

I am unsure how to get the correct bin to work.

I’m having the same issue with the 8mb variant, I’ve tried every version of wled for the s3 but non will boot. I can flash tasmota or espeasy without issue. I’ve tried updating from those directly to wled however that doesn’t work either. I really don’t know what to do at this point. I’ve tried with the 4mb variant however that isn’t working for me either.

4mb build:

8mb build:


I’m not sure what’s going on…

I’ve built most of them just to see.
I’ve split the line so you can see all the binaries.

Is the one you mentioned in this list if it is?

I understand there is prep?
1 Boot
2 Partition?

What do I actually need to Do to get these variants working please…

To add, I’ve already tried both builds listed here flashed via esptool neither of which work.

you can flash it directly from VS code

I hear ya… I’m. Not saying I’m having success with this… Incase my words are confusing…
Just showing how many things I’ve tried…
But to say I do have a mini… And normal esp32. Hence the other builds

How to flash from vs code in one easy step lol

I’m listening

There is an “Upload” entry (and button) in PIO environment tree. Just beneath (or next to) “Build”.
You do need to add upload_port to your environment, though.

I followed this guide.


I love these type. Of answers…

IT’S really Easy. Just use this simple switch… Click…

But make sure you’ve calibrated thruster 9 thru 15… Remix fuel. In chambers 3 pre ignite. Set geo loc system to 5.2… Fix gyros at 81.43 degrees. While you at it split the atom 8.62 different ways as all eons will be required. Ensure system biology is self certifying and engaged.

As long as you do that easy but then the switch will work…

I’ve No clue.