ESP32C3 mini v2 & DS18B20

Next try with Lolin ESP32C3 mini:

extends = env:lolin_c3_mini
board_build.partitions = tools/WLED_ESP32_4MB_1MB_FS.csv
build_flags = ${common.build_flags} ${esp32c3.build_flags}
  ; DEBUG reserves GPIO1
lib_deps = ${env.lib_deps}
  makuna/NeoPixelBus @ 2.6.9 @ 1.2.0

Just can’t get temp sensor to work, compiles just fine and leds work just fine.
Leds in pin 6, onboard led in pin 7, sensor pin 8.

I need to add, I’m using MM fork.

@moykky have you only tried pin 8? It looks like from the datasheet that’s a strapping pin so maybe some interference? GPIO3 looks like a good bet from what’s listed if you’ve got it free.

just my.02, I couldn’t get a Dallas working on the S2 mini either, and it’s still a couple of weeks out for my V2 C3s to try it out.

FWIW I used the SHT usermod with an SHT30/S2 mini and that is working well if you have one around.

No, have not tried another pin yet than pin 8, thanks for the headsup.
I’ll try GPIO3 asap and report results. :+1:

I don’t have SHT3x sensors around, DHT21:s I have but they are not waterproof.

I do not see details of your Lolin ESP32C3 mini board version that worked well with leds and audio , is the c3 board marked V1. or V2

I did not mention anything about audio, leds work fine.
Sorry, board is v.2.

Thank you , its fine , It is just to avoid confusing others , you said leds work just fine and in your build env you showed -D USERMOD_AUDIOREACTIVE . As of now Lolin ESP32C3 mini v1.0 has being conformed to have issues even on tasmota site . your build above did not work at all for us on multiple V1.0 units ( no AP and other major issues so not working at all on v1.0 )

For v2 which you have we are yet to see anyone use audio and wanted to confirm . Unfortunately we only got some Lolin C3 mini v1.0 which should be avoided as they are still being sold without reference to hw concerns

Yes, audio is just a option for future purposes.
Did a double check and board is v.2.1.0.

I’d love to have temp sensor included my outside terrace lights controller.

Did not know about this issue with v1 and really happy have 10 v.2.1.0’s.

I could not say about c3 v2 peripherals as our v2 is yet to arrive . For v1 refr to hw issue here ( also s2 v1 should be avoided ⚠️ Lolin Wemos C3 mini needs hardware mod to work ⚠️ · arendst Tasmota · Discussion #15443 · GitHub

no luck with GPIO3 neither even with 4.7k resistor.

4.7k is way too big.

@moykky I had the Dallas working for about an hour on a V2 C3, but now I’m running into a bunch of little hiccups. Sometimes boots, sometimes not. Random freezes and disconnects. Trying the process of elimination to see why it’s not stable. I had the Dallas on IO21(Tx) just to see what would happen and thought that might be the problem, but with the usermod disabled I still have the connection issues. I haven’t been able to try another IO pin yet.

I’m not sure how many extra features you need for your build, but I’m starting with just the temp usermod to see if I can get that working reliably. Everything else about your connections sounds good to me, I’m using the same resistor for the Dallas, etc. I’ll update with anything new.

There is still hope. :grinning:

First boot with Dallas on IO21:

It’s pull-up resistor between 3.3v and sensor pin.
Values between 3.3k-4.7k have been suggested somewhere (can’t find link anymore).

Well to be honest, I need only temp and leds working atm.
These leds will be outside terrace and I’d love to have temp sensor integated.

AFAIK, my build is stable otherwise. Maybe I’ll run some long tem test.

@moykky I seem to have the Dallas working in a test setup with 40 leds now. Still using IO21. No reboots or freezes, presets save, etc. Using Aircookie’s main with the Temp usermod.

I didnt set any pins in the build, just did it after boot from the UI.

I know esp pins don’t want to see over 3.3V, so I don’t recommend doing this but I’m powering my temp sensor with 5V. So far so good, but we’ll see.

I tried the MM fork too, but even with the Dallas disconnected, whenever I try to set the sensor pin, the C3 panics and goes unresponsive. Tried every pin option available. Everything else works fine though. Not sure if that happened to you?

Also, I was wondering if your sensor is close to the board or further away? Everything I see says max 10m or so, but I haven’t tested myself. If everything else works for you it seems like something specific to the sensor wiring maybe?

Working setup:


MM setup (temp not working):