Looking for a binary Usermod WLED with activated DS18B20 Temp. Sensor

Hello all,

I’m unfortunately just a Hardware guy and not familiar with Software and compiling.
I tried it anyway, but I’m running in a lot errors, like “command ‘platformio-ide.build’ not found”, Docker retunrned an error and “Intellisense is not configured”… I have no idea to fix this all and it drives me crazy!!!

Have anybody a created binary for Wemos D1 mini with activated DS18b20 temperatur sensor?

Thank you!

Pick any you need WLED-wemos-shield/resources/Firmware/@Aircoookie at master · srg74/WLED-wemos-shield · GitHub

Thx for your help, but I can’t find a binary for D1 and Dallas sensor.

I tried several times to build something.
When I copy this “platformio_override.ini” to the main folder I run into problems.

Display mode can be disabled:

Ah, ok, thank you. It works!

But why I can’t compile, when I copy “platformio_override.ini” to the main folder?

Whats about the files " usermod_temperature.h" and " usermods_list.cpp"?
I have to copy them anywhere as well?

Just make a copy of my fork and use ‘env’ you want GitHub - srg74/WLED at Shileds

Sorry, I don’t understand what you mean with “fork” and “env”.

Dallas Sensor works with your image, but I want to compile by my own.

So I tried with DHT usermod, but at the WLED webserver I can’t see DHT in Usermods.
WLED says “Usermods configuration not found.”

I did following:

Copied regular WLED source code and copied WLED/platformio_override.ini at main · Aircoookie/WLED · GitHub
to the main folder, where platformio.ini is located.

At platformio.ini I commented out:
“default_envs = nodemcuv2, esp8266_2m, esp01_1m_full, esp32dev, esp32_eth, esp32s2_saola, esp32c3, esp32s3dev_8MB”
“default_envs = esp32dev, esp8285_4CH_MagicHome, codm-controller-0.6-rev2, codm-controller-0.6, esp32s2_saola, d1_mini_5CH_Shojo_PCB, d1_mini, sp501e, nodemcuv2, esp32_eth, anavi_miracle_controller, esp07, esp01_1m_full, m5atom, h803wf, d1_mini_ota, heltec_wifi_kit_8, esp8285_H801, d1_mini_debug, wemos_shield_esp32, elekstube_ips”
and uncommented
“default_envs = d1_mini”

In the file “usermods_list.cpp” I uncomment “include “…/usermods/DHT/usermod_dht.h””

Then I compiled and flashed into Wemos, but there I can’t see DHT in usermods.

What’s about this stuff?

; USERMOD_DHT - define this to have this user mod included wled00\usermods_list.cpp
; USERMOD_DHT_DHTTYPE - DHT model: 11, 21, 22 for DHT11, DHT21, or DHT22, defaults to 22/DHT22
; USERMOD_DHT_PIN - pin to which DTH is connected, defaults to Q2 pin on QuinLed Dig-Uno’s board
; USERMOD_DHT_CELSIUS - define this to report temperatures in degrees celsious, otherwise fahrenheit will be reported
; USERMOD_DHT_MEASUREMENT_INTERVAL - the number of milliseconds between measurements, defaults to 60 seconds
; USERMOD_DHT_FIRST_MEASUREMENT_AT - the number of milliseconds after boot to take first measurement, defaults to 90 seconds
; USERMOD_DHT_MQTT - publish measurements to the MQTT broker
; USERMOD_DHT_STATS - For debug, report delay stats

Do I have to uncomment this?
I tried it, but got an error.

Can I use 2 sensor, like Dallas DS18b20 and DHT at one board togehter?

Sorry for my asking, but as I mentioned, I’m not a SW developer.

You have to study user interface of Platformio. There is a way to choose one of the environment (env) and compile. Nobody mixing 2 different sensors in one board but you can try it might work.