How to properly add a custom usermod (Usermods configuration not found)

Hi community,

thanks in advance for you help!
I am trying heavily to bring a custom usermod to my WLED compile on ESP2866 (via PlatformIO and Visual Studio Code), so far without success… Can you maybe help me here?

I have added my usermod file to a separate folder in the usermod directory.
Then I added the usermod specification in both places in wled00/usermods_list.cpp, as described.

Finally, I copied the d1_mini environment to the platformio_override and added
build_flags = … -D MY_USERMOD
lib_deps = … ESP8266HTTPClient
(the latter being required for my usermod, otherwise I get a compilation error).

Now I am able to compile, and WLED is running on my ESP2866, but the usermods section in the GUI still says “Usermods configuration not found.” :frowning:

Can someone help me? Probably I am doing some stupid mistake, but unfortunately I couldn’t find better help regarding my question after 4 hours of research…

Usermod will only show in settings page if you configure it to do so (addToConfig()).
Please examine existing usermods, there are plenty, and try to duplicate what is done there. There are plenty of instructions available in readme files of existing usermods.
If you are still stuck, publish your work on Github so we can see what you have done and try to help.