VSCode status bar BUILD icon press fails - latest WLED and VSCode+Exts

WLED is just the best - big big thanks Aircookie.

Got a most minor issue with a clean install of VSCode and fresh pull of WLED (0_15); the BUILD icon in the status bar (the tick) would fail to trigger a build. The UPLOAD icon works and does a build if required. Unknown if relevant, was building Elekstube IPS usermod version.


I removed the WLED/.vscode/tasks.json file that gets delivered in WLED, restarted VSCode and now the BUILD icon click works correctly. Nice!

Anyway, hope this helps someone.

Check Workaround

Thx, had tried DELETE (tried all the shortcut actions trying to discover the problem), didn’t resolve the issue. Remove this snippet from the .WLED/.vscode/tasks.json resolves the problem.

      "type": "PlatformIO",
      "label": "Build: binary only",
      "task": "Build",
      "group": {
        "kind": "build",
        "isDefault": true
      "problemMatcher": [
      "presentation": {
        "panel": "shared"

Maybe someone officially (f.e. @blazoncek) will take your solution into account and fix this in general. Actually building WLED is not possible as described in the docs. Mainly I wanted to link your solution to the ‘delete’ workaround, to avoid more threads popping up with the same ‘can’t build WLED’ issue …

I am not willing to tackle such minor problem as deleting pre-filled “Build” dialog (which was caused by VSC and/or PIO update) resolves build issue.
I know it is PITA but I am no MS VSC + PIO + CI expert so my resolution is just to remove pre-filled entry.

In any case, you can select desired build environment (second next to upload button) and build will work for your chosen environment.

You are welcome to update documentation if you think it needs clarification.