Web interface fails to load (b/c of DDP?)

Hi, I wanted to test multiple controllers + multiple leds, and set up this simple test:

Esp32 A
| --pin14-- WS2812B x10
| --pin33-- WS2812B x10

Esp32 B
| --pin14-- WS2812B x10
| --pin26-- WS2812B x10
| --pin33-- WS2812B x10

Esp32 C
| --pin14-- WS2812B x10
| --pin26-- WS2812B x10
| --pin33-- WS2812B x10

All 3 ESPs received IPs and I was able to control them via network.
I then configured A to use B as 30 DDP leds, and then added C as another 30 DDP leds.

This seemed to work for a minute, but now A’s interface loads with “Connection to lights failed!” that quickly turns to “TypeError: failed to fetch”.

Additional info:

  • The web interface always loads (partially), and I can navigate to settings.
  • Pinging the IP works fine
  • I tried removing the DDP leds, but when I save new changes they seem to be rolled back when I check the settings again.
  • After disconnecting one or both of the other (DDP-controlled) esps, the problem still persists
  • resetting or disconnecting the esp from the power source did not help

EDIT: here is a Serial log after rebooting the problematic esp

Do you have them all connecting to one, or to your network?

All connected to my network.
I just checked the Serial console as well, I’ll edit my post to add the log.

Try reducing FPS in advanced settings to 25.
You may need recent build though.

I’m custom compiling from main branch (no changes except duplicatiing an effect for testing).

I tried reducing the FPS, but as with the led config, settings are not retained with the Controller.
(I get “Led Settings saved”, but when I return to the settings page it is the old value (42) again).

Reflashing doesn’t work either.

However, for now I’ve simply switched to using different Esps, and am not using DDP as heavily yet.
So possibly it could be EEPROM/flash corruption, though the serial logs do seem DDP related.

I’ll keep an eye out and reply here if the same thing happens with another Esp.

If the settings are not saved you have file system issue.