WS2811 leds suddenly start flashing

No segments set up but when running default palette with some effects, some colors (especially white) will start flashing. Sometimes powering off the ESP8266 MCU will correct it. Just wondering what might cause that. 12v fine, 10000mA set, rest at defaults. 450 pixels total. Other colors occasionally flash but not often. running 0.10.0.

Hi!
Sounds like the data signal voltage is not high enough to drive your LEDs.
This likely requires a hardware fix. See https://github.com/Aircoookie/WLED/wiki/FAQ#reason-2 :slight_smile:

Aircookie, thanks so much for the response,

I agree that it sounds like weak data, but:

  1. Controller is 2M from first string AND I am using a sacrificial LED (as you suggested)

  2. The nine subsequent strings of 2811s are connected directly to each other thru the default connectors. 12v is additionally injected at 3 other spots and the end. I notice the flashing at about string 5 (not so much at the start of the LEDS)… and all the LEDS respond so the data is making it to the end. Each pixel regenerates the 5v signal… so I wonder where the data level is dropping. How can I measure it without an O scope or analyzer?

  3. Would a different chip work better? ESP32?

  4. Your code is amazing. I am so grateful for your original work and continued development.

John

1 Like

How many power supplies are you using? More than 1? If so, make sure the 0V outputs of all the power supplies are electrically connected (bonded) together somewhere - preferably close to the power supply output terminals/connections.

Only one 300W power supply.

300 W 12 V power supply can provide ~ 25A of current.
450 RGB full white @ 75mA each ~ 33.75A
WLED configured max ~ 10A
I say increase the configured max to 20A and see if that improves things.
Of course, make sure the wire coming out the power supply to the first fuse can handle 25A (in case of a problem).

Please don’t think TLDR on this. Thank you.
I’m having a very similar problem and it seems hardware related but I don’t know what the solution is.
Background: I’m new to trying this stuff out but I worked as a developer for several years so I’m not a total stranger to microcontrollers, circuits and code.
I watched a few of Dr. ZZZs videos on YouTube and got very excited about using WLED to run some permanent lights on my house so I wrote down all the items he suggested and bought them and got everything set up on the floor to test before installation but I can’t get past the flashing LED problem.

Here is the set up I’ve been trying for about a month now and still have the flashing problems:
I have 12V WS2811 LED Strings. I’m using NodeMCU with WLED 0.10.2. I bought a bare metal 12 V 50 A power supply and I have an LM2596 connected from the power supply to the NodeMCU to drop the 12 V to 5 V so I don’t pop the NodeMCU. (I’ve actually tried both dropping it to 5V and to 3.3 V with the same flashing results). Also, all Grounds are tied together.

If I connect a single 50 Count LED string and turn the amps to around 250 mA sometimes I get the desired behavior but if I add more strings and turn up the amps to drive them, some of the effects work fine but when I try to just use Solid, the LEDs flash bright, then a bit dimmer, then dimmer still, then a bright flash of some random other color for a half a second or so, then they go back to the chosen color and randomly repeat the cycle. I’ve read some people have flashing problems every 20 minutes or a couple times an hour. My flashing is every few seconds.

The other day I grabbed an old X-10 power supply that I don’t use anymore whose label states 12 V and 200mA and wired it up to a single string to see if that would help. This gave me the desired results. When I choose a solid color it goes to that color and stays there with the current limiting setting at 250mA (the minimum it will allow, even though the walwart power supply only says it outputs 200mA) One thing to note, eventhough it says 12 V when I measure the Walwart output it’s actually 19 V but the 12 V LEDs don’t seem to mind. (I tested it on a sacrificial one first) I can use the little Walwart to power 2 or 3 strings and it sometimes does ok for a bit, but then if it’s all a solid color at too strong of a brightness it can pop the NodeMCU off and the lights just stay on however they were when the NodeMCU dropped out or they turn off too.

I’ve tied the grounds together, I’ve tried the sacrificial LED, I’ve turned off the current limiting seting and I always end up with the same results when I try to put more than one string in the line. I have spent quite a long time reading up on how to fix this and watching various YouTube videos from this great community, but I still have something wrong and don’t really know what to do to fix it.

The big difference I see from my setup compared to everyone’s samples is that most people use 5 V LEDs and if they are using 12 V LEDs in their demo they only ever show one string or strip running and the power supply is just a wall plug, not a bare metal one. As far as I can tell I’ve done everything people have said to do to solve the issue yet I keep seeing the same issue. I’ve even flashed the NodeMCU with older firmware versions to see if it’s the code but it seems the code is fine as is proven by using the walwart with just one string, but how can I fix this problem to make it is so I can do some longer runs?

My data line from the NodeMCU to the first LED is about 20 cm unless I use the sacrificial LED, then it’s about 3 cm. Either way I get the same results. I tried to look up the desired voltage to drive the LEDs and didn’t find the answer. The WS2811 datasheet says +6V to +7V is the voltage to the actual chip so obviously with the 12 V strings they are dropping it down a bit. I’ve read about using the levelshifter but I don’t understand why that would help when it’s the same as using the sacrificial LED, right?

If you’ve seen this problem as I’m describing it and can think of anything else please let me know. I’d love some guidance.

Ok first up I would only use a power supply of higher amperage capacity than you need and use a supply that outputs correct voltage to your pixels. This way you won’t need to muck around with setting current limits and voltages.

With regards to flickering have you tried the below circuit, it sorted all my problems.

Thank you for your reply.
I have tried adding a 460 Ohm resistor (didn’t have any 330’s lying around), but that didn’t help. A couple of differences I notice here are:

  1. I didn’t feed the ground line from the sacrificial LED to the ground on the string, I just used the ground from the power supply that is common among all things. (I don’t imagine that’s the difference as it shouldn’t be causing a floating ground since the ends of the strings are in the same situation, but I certainly try that modification.
  2. The strip in the image is a 5 V strip where I am using 12 V strings, so not sure about the diode part.
    What size is that diode in the image?
    I’ll see if I can find a 330 Ohm Resistor to put in the equation, then I’ll post the results.
    I really appreciate you taking time to read my long explanation and for replying. Happy Lighting!!

@Keebler14 Hi! I wouldn’t say that 200mA walmart supply is suitable for anything really. Even for just a strand of 50, you’d want an amp or so.
What did you set the brightness limiter to with the 50 amp supply? Since that is so much, you should be safely able to disable the brightness limiter entirely.

To get rid of the flickering though, try @Modelman 's solution (not the resistor is key, but the diode!) Sacrificial pixel should be a 5v one, connect its 5v to the nodemcu, not the 12v of course)
If you want a very robust solution, consider getting a prebuild QuinLED Dig Uno, they are worth every penny for a large setup (and even have a built-in voltage converter) and with the built in SH74HCT125N levelshifter (which you could also add on its own) all the flickering should be gone!

The resistor is not a necessity however I discovered on very long data runs (more than 4m) it added additional stability and completely eliminated any occasional flicker. The QuinLED Dig Uno or Quad is a great bit of kit however the above circuit does work and is ideal for those on a tight budget. It’s also very easy to construct.

Aircookie, I appreciate you taking time to respond. I didn’t think the 200mA supply would handle much but when I saw the flicker disappear on one 50 LED string I convinced myself that the problem was in the electronics and not the software/firmware. I just used it for a quick test. Plan has always been to use the 50 amp supply.

I have tried various levels in the settings from 250 mA to either 30 or 40 amps. Since I haven’t connected more than 3 strings together so far I don’t remember the max I’ve used. I’ve tried turning it off as well which so far yields the same results. So I’ll just leave it off.
I don’t have any 5 V LEDs so I’ll have to get a string of those.
I do have a handful of 1KV diodes. I did put one in line once per the diagram, but with a 12 V sacrificial LED not a 5 V as you suggest.
Sounds like I should just commit to the QuinLED Dig Uno since I do plan on a large set up (basically my entire roof line).

Thanks again for the replies. I am very grateful.

Modelman, Thanks again. I think I’ll look into the QuinLED Dig Uno or Quad and then also try the lower budget method for some smaller projects.

Just to circle back and give a big thanks to Aircookie and Modelman. I ordered a 5 V string of LEDs which showed up today. I cut out one 5 V LED, used it as a sacrificial LED and soldered in a diode per the instructions in the diagram. Now with 6 strings of 12 V LEDs (300 LEDs) no more flashing. Thank you, Thank you. Happy Lighting!!!

1 Like

Your welcome…Glad you got it sorted.

These sorts of issues can also be due to noisy power supplies. Cheap power supplies can have a ton of AC ripple which will cause all sorts of strange behavior. Also I have noticed the 3.3V output of some ESP8266 boards to vary enough that some work great without a logic shifter and some don’t. It is probably best to use the logic shifter and get the signal level to 5V which will greatly improve noise resistance on the data line. I have also noticed that many USB power adapters are extremely noisy as well.