Adafruit Matrix Portal S3

Has anyone had success with this board? I’ve looked through the forums here and tried installing binaries that seem to match ESP32-S3 / 8 MB, but without any luck. Many thanks for any help!

@netmindz can you possibly help?

You can try using the firmware-adafruit_matrixportal_esp32s3 build from here Disable HUB75 for V4_M builds due to space issues when building on wi… · netmindz/WLED@d0fe878 · GitHub

Thank you so much for responding. I tried the firmware which seemed to install ok, but when the board restarts I see this in the terminal

ESP-ROM:esp32s3-20210327
Build:Mar 27 2021
rst:0x7 (TG0WDT_SYS_RST),boot:0x8 (SPI_FAST_FLASH_BOOT)
Saved PC:0x40043ac8
SPIWP:0xee
mode:DIO, clock div:1
load:0x3c110020,len:0x4e9f0
load:0x3fc971a0,len:0x1600
load:0x42000020,len:0x101dac
Invalid image block, can't boot.
ets_main.c 329 

I erased the flash and then esptool.py write_flash -z 0x0 adafruit_matrixportal_esp32s3.bin

I don’t use esptool so can’t comment if that’s correct. You could try one of the web based installers of WLED then goto the manual ota page in settings and upload that file

Thank you. I was eventually able to get it installed via PlatformIO. Seems to work great now!

Oops, I spoke a little too soon.

The board only boots properly after I make a serial connection, i.e. if it is connected and powered directly from my laptop, and after I screen /dev/cu.usbmodem101 115200. If I power the board from its own power adapter, WLED doesn’t load, presumably because there’s no serial connection to prompt it to start running. Not sure what’s going on there. I do see some pin conflicts in the logs (e.g. PIN ALLOC: failed to assign GPIO35 to Hub75 - already in use for PSRAM.) once WLED launches.

Another issue is that WLED seems to crash when trying to save LED settings like the preset to use on boot.

@netmindz I can create issues on GitHub if you think it would be helpful. Please just let me know.