Animated stair case Mod

Hi All

Can any one help me here please.

I have compiled for esp32 & D1 Mini with stair code enabled

under

[env:d1_mini]
board = d1_mini
platform = ${common.platform_wled_default}
platform_packages = ${common.platform_packages}
upload_speed = 921600
board_build.ldscript = ${common.ldscript_4m1m}
build_unflags = ${common.build_unflags}
build_flags = ${common.build_flags_esp8266}
 -D USERMOD_ANIMATED_STAIRCASE
 -D USERMOD_DALLASTEMPERATURE
 -D TEMPERATURE_PIN=23
 -D WLED_DEBUG
lib_deps = ${esp8266.lib_deps}
monitor_filters = esp8266_exception_decoder

Unfortunately it doesn’t work keep getting error 9

image

It looks all settings are inside of “cfg” file but its not taking any commands through curl.

Can any one help me to get file for esp32 mini compiled with Temperature sensor & Animated stair enabled.

Probably im doing something wrong

Thanks in advance

Regards

Sensors working.

I had same setup before with custom code and im even wired sensors to same pins but Wled not having it

image

image
even with success return it wont do anything

I believe there might be a parameter in the staircase mod that you’ve assigned a value of 0. Unfortunately, the mod is not written to accept a 0 and still perform properly. (This last part may not be true today, but it was earlier in the year).

Thanks for your time got it resolved in the end.

0.13 didnt worked. So downloaded 0.13.1 only 2 stairs worked. Then new release of 0.13.2 came out and this version worked like a dream.

Regards