Cannot Break one segment into Two (13 b5)

I have a working WLED instance (running 13 b5 now, but started with b4) with a single 120 LED SK6812 strip/segment. Works perfect!

I want to break it into two segments, both 60 LEDs long. I edit the first/existing segment, change the Length from 120 to 60 and press the Save check mark button. Seems to work fine.

Then I press the Add Segment button. It only has the Start and Length fields (I assume the other things come later) and I set that to 60 start and 60 long.

When I press save, the new segment UI element goes away and a briefly showing message at the bottom says “You need to have multiple segments to delete one!”. Of course, I don’t have multiple segments and I’m not trying to delete one.

I WAS able to do this on another WLED 13 b5 instance (though I split a 64 LED strip into two 32 LED strips). Worked great and UI elements/process worked exactly as my other example - only difference is that it was saved off.

These are both on ESP-32 units (same exact model). Tons of available memory/RAM.

I’ve tried using other numbers (like 0-60 and 61-70) just to make sure there was no overlap, though the same numbering scheme worked great on my other, successful test case. So I don’t think it’s that.

The ONLY difference I can find is my problematic WLED install is using SK6812 LEDs and the other test case that worked uses WS281x settings. Can’t see how that would matter, but going through all the settings one-by-one, this is all that differs.

Any thoughts on what I assume I’m doing wrong when trying to split up my existing strip into two?

Thanks for any pointers!


1 Like

I’ve hit that issue sporadically in the past but have never been able to pin the sequence down.
Between upgrading versions, playing with multiple pins and doing a full power reboot of the chip I’ve always had too many variables to say “Aha that fixed it!”

Try the power boot, that has helped on occasion.
Try to build a brand new preset and add the segments there.
I use SK6812, WS281x and others with no differences.

All I can say is once you get WLED to recognize you want two segments it’s fine from then on…

Thanks - I had done both of those before, but heck, easy enough to get it mixed up, so did a full reboot (power off reboot, to be super clear) and it didn’t change above behavior. Started a new preset and that didn’t change how it worked.

Even added a new preset with a single segment with just the 1st 60 LEDs (thinking I’d go back and add the 2nd segment after the preset was saved). No change.

Are you sure the UI says “Start” and “Length”, or does it say “Start” and “Stop”? Using length instead of stop can be enabled in UI settings, but stop is the default. If it says stop, you’ll want to enter 120 for the second segment.

Good point - I’ve see that before. But these are showing start and length.