Cannot install on 2 different ESP32 devices

Hi everyone,

ESP newb here. I have a bunch of LED equipment and trying to get a working controller. I have one digi-uno which is ESP8266 based. That flashes fine and I can control my equipment without issue, however I’d like to add things like sound reactive, plugins (MoonModules?). All that stuff seems to be best on ESP32 devices? Either way I got myself 2 different types. One is the Inland ESP32 board form MicroCenter, the chip is ESP32-WROOM-32. And the other is the NodeMCU ESP32-C3-M1-Kit, the chip on this one is the ESP32-C3-M1. I have tried every trick I find on the internet but I can’t get WLED to work on either.

I’ve done the web install, no luck on the WROOM, the C3 it just tells me from the start no. To be clear, when I say no luck, I can get the device to flash but the WLED AP never shows up. When I look at a serial monitor I see the port bouncing up and down, if I hold the buttons down to control the boot while connected to the monitor I can see WLED initialize but the “ada” and the monitor disconnects. TO me it seems like it’s in a reboot cycle.

I’ve also tried the manual install using ESPTool (both exe and py). Clear the flash, flash the boot loader (tried v2 and v4), flash the BIN (tried several different variations of this on both devices, both base WLED and modded). This doesn’t work for either device also. Sometimes the device ends in what appears to be a boot cycle like described above. Other times I see a littlefs error.

And yes I’ve tried compiling form source using PlatformIO in VSCode. I think I figured out what to do there, tried several different environments for both board, again same basic results.

Really hoping someone can help me. If I can even get a base WLED on these working I can go from there. Any pointers are appreciated!

ESP32-C3 support at early alpha. ESP32-wroom should work no problem. Download from here WLED ESP flasher tool WLED-wemos-shield/resources/Firmware at master · srg74/WLED-wemos-shield · GitHub and firmware bin file you would like and try.

Yeah, I’ve tried those too. I’ve used that ESP Flasher tool, as well as 2 other variants (seem like older versions). I’ve tried several different images from that site. All of them seem to result in the same thing.

Do you have anything connected to the ESP32 when you do this?

As in LED strips or sensors or anything else connected to the GPIO pins? No, just the ESP attached to to the controller board. It is usually plugged into the USB cable of course, and yes I’ve done the button thing. The flashing seems to happen normally (progress goes to 100% and such).

WLED esp flash tool is different than ESP flasher

Which controller board? You may need to disconnect it.

I’ve been working with 2 different boards. The first is just labeled Inland ESP32 board form MicroCenter, the chip is ESP32-WROOM-32, and the other is the NodeMCU ESP32-C3-M1-Kit, the chip on this one is the ESP32-C3-M1.

I have tried the WLED ESP Flash tool and a couple of variations I’ve found, the command line python esptool, the command line exe esptool. Nothing works.

Try Serg’s flasher along with his bin files.

Note that the C3 is experimental still.


Sorry, been busy so haven’t had a chance to get back to this until now. I just tried flashing the ESP32-WROOM-32 device using the flasher and images from the site above but not seeing any differences.

I flashed WLED_0.14.0-b2_ESP32-WLED-sound.bin from Aircookie and it flashed just fine but afterwards the device seem stuck in a reboot loop posting this in the serial console:

[21:45:32]ets Jun  8 2016 00:22:57
[21:45:32]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[21:45:32]configsip: 0, SPIWP:0xee
[21:45:32]mode:DOUT, clock div:2
[21:45:32]entry 0x400805e4
Serial port closed!

It just seems to be boot looping doing that.

I tried one of the MM modules images (WLEDMM_0.14.0-b15.22_esp32_4MB_M.bin) and got this

Showing logs:
[21:49:22]ets Jun  8 2016 00:22:57
[21:49:22]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[21:49:22]configsip: 0, SPIWP:0xee
[21:49:22]mode:DIO, clock div:1
[21:49:22]entry 0x400805e4
[21:49:22]---WLED 0.14.0-b15.22 2304080 INIT---
[21:49:22] WLEDMM_0.14.0-b15.22 esp32_4MB_M, build 2304080.
[21:49:22]CPU:   ESP32-D0WDQ6 rev.1, 2 core(s), 240MHz.
[21:49:22]CPU    Restart due to power-on event (code 1). Core#0 power-on (1); Core#1 restart (14).
[21:49:22]FLASH: 4MB, Mode 2, speed 80MHz.
[21:49:22]Mount FS
[21:49:22].pio/libdeps/esp32_4MB_M/LittleFS_esp32/src/lfs.c:1078:warn: Superblock not found (dir pair at {0x0, 0x1}). Filesystem needs formatting.
[21:49:25]done Mounting FS
[21:49:25]Usermods setup ...
[21:49:25]Finding temperature pin...
[21:49:25]temperature usermod initialized.
[21:49:25]PIN ALLOC: failed to assign GPIO18 to Rotary Enc. (UM) - already in use for Temperature (UM).
[21:49:26]AR: sound input driver initialized successfully.
[21:49:26]mpu setup
[21:49:26]mpu6050: warning - ivalid I2C pins: sda=-1 scl=-1
[21:49:26]GPIO	| Assigned to		| Info
[21:49:26]i/o   0	  ./.               	  
[21:49:26]i/o   1	  ./.               	  Serial TX
[21:49:26]i/o   2	  ./.               	  
[21:49:26]i/o   3	  ./.               	  Serial RX
[21:49:26]i/o   4	  ./.               	  
[21:49:26]i/o   5	  ./.               	  (default) Rotary CLK pin
[21:49:26]i/o  12	  ./.               	  
[21:49:26]i/o  13	  ./.               	  
[21:49:26]i/o  14	  AudioReactive (UM) 	  
[21:49:26]i/o  15	  AudioReactive (UM) 	  (default) mpu6050 INT pin
[21:49:26]i/o  16	  LEDs (digital)    	  (default) LED pin
[21:49:26]i/o  17	  ./.               	  
[21:49:26]i/o  18	  Temperature (UM)  !! Conflict with Rotary Enc. (UM) !!	  (default) Rotary DT  pin
[21:49:26]i/o  19	  ./.               	  (default) Rotary SW  pin
[21:49:26]i/o  20	  ./.               	  
[21:49:26]i/o  21	  ./.               	  (default) DHT temperature pin
[21:49:26]i/o  22	  ./.               	  
[21:49:26]i/o  23	  ./.               	  
[21:49:26]i/o  25	  ./.               	  
[21:49:26]i/o  26	  ./.               	  
[21:49:26]i/o  27	  ./.               	  
[21:49:26]i/o  32	  AudioReactive (UM) 	  
[21:49:26]i/o  33	  ./.               	  
[21:49:26]in   34	  ./.               	  
[21:49:26]in   35	  ./.               	  
[21:49:26]in   36	  ./.               	  
[21:49:26]in   37	  ./.               	  
[21:49:26]in   38	  ./.               	  
[21:49:26]in   39	  ./.               	  
[21:49:26]WLED initialization done.
Serial port closed!

And again the device seems to be stuck in a boot loop posting the same thing to the console. No AP ever shows up.

Try to install from this site directly WLED installation ( and i hope we are not talking about C3

Tried that site also, essentially the same result. Detailed results depend on which image is used but it is essentially the same as above. And no currently I am working with the ESP32-WROOM-32 device since many people seem to say they hace those working.

Site is working for us with both AC and MM and I do not see anything wrong with the log you posted , where do you see boot loop or something saying rebooting else look for the AP ,
I am not sure about if you get this every time

21:49:22]CPU    Restart due to power-on event (code 1)

And just in case show the board you have

I believe it is in a boot loop because the serial monitor always disconnects after the “ada” is show in the log after the wled init. The AP never shows up and if I constantly reconnect the serial monitor I see the same log messages but with newer time stamps. And on my ESP8266 which works fine the last message I see in the serial monitor is it putting up the AP, but I never see that on these devices.

Here is the ESP32-WROOM-32 board I am using. I’ve given up on the C3 boards for now.

Please also note. The site you gave me works fine in my 8266 board. And it flashes fine for these boards but the results on the board are the same if I manually flash.

Hope its alright to post this here, i dont really do much of this but been looking for the solution to a problem iim having which seems to relate to the issue you described so thought id just ask right here since the convo kindof stopps… did you get this working? Been having the same issue now with my 3rd esp wroom 32 dev kit. Only thing is when they were new they all 3 flashed fine and ran fine but after trying to update not using the app but flashing from my notebook i get that bootloop you described in your post. It gets through to 100 percent and toasts flash success using the online flasher page but then right away after pressing the rst or the boot button it starts to boot loop, Or if you just unplug it and plug it back in before pressing anything it boot loops right away, the com port just open and close and the terminal spits out the same 5 or 6 lines of whatever it says just repeatedly in time with the port opening and closing until it gets unplugged. Tried all the different flashers i could run across online as well as other variants of the wled firmware sound reactive, and so on. I gave up on that board and then after some time it started doing the same thing on my second board and here lately my third. Is it an issue with hardware possibly? Any help from anybody reading this that has a fix or something more than saying i cant post this here or the always favorite go search the forums blah blah thing i see alot. Anyways, delete this if its in the wrong spot. thanks

No, I never got it working. And unfortunately it caused me to just give up on WLED for a while. Going to have to wait until I get more time. Sorry. If you do find a solution or have some ideas to try, reply here and I’ll give it a shot.

The solution is pick the port, hold down the left button EN while you click install on wled install site or flasher.