Cannot get WLED onto ESP32

please excuse any errors in phrases or misspelling,

I have a data cable and an esp32, I’ve tried the [intall.wled.me] installer. Once plugged in the light comes on red, in the pop up window I have a spp server com3 and Bluetooth peripheral device com4, in the videos I always see the second option selected (paired) I selected that, I follow the prompts to install, hold the boot button, I’ve tried holding both buttons and no buttons, every time I get the same error (failed to initialize Try resetting your device or holding the BOOT button while clicking INSTALL) held down both buttons and it got stuck on preparing to install.

I’ve tried installing the ch340 driver but when I run the exe file and click uninstall as I’ve been instructed it says no device found. If i just click install it flashes a couple windows and then says driver is already preinstalled.

I do see it come up in the wifi settings when plugged in but if I connect to it then I cant do anything.

Also tried the path through another youtube video that went with a code writer python and I got lost almost instantly because I’m not a code writer, I see all the videos have c:\user\ and then their user name but idk what mine is even, I’ve tried just entering the bootloader file but after I copy and paste I just get the … after pressing enter, I try entering the bin and get invalid syntax I’m a wood worker who has been tasked with learning LED’s for a job. I am genuinely interested in LED’s so this would be awesome to learn I’m just so new. Any help is deeply appreciated, probably going to have nightmares about this tonight, luckily I have a week to figure this out before install.

I should note I got the chip off amazon in a 2 pack. Reading reviews on the chip, dont seem to be different than other chips 1 star reviews, but I could see it being possible its a bad chip/manufacturing issue. Is there a supplier or seller thats more trusted possibly on amazon?

I would try and see if you can get installed using esptool

Download esptool

Download bootloader

Download WLED binary

  • Connect esp32 to pc

  • go to http://install.wled.me and click on install. When the com port # comes up take note of it and close out of that. You are only going there as an easy way to determine your com port.

  • Unzip esptool.

  • Open the esptool folder and put the downloaded esp32_bootloader_v4.bin file and the WLED_0.13.3_ESP32.bin file in the folder.

  • Click in the folders address bar. It will highlight the full path. Hit Ctrl C to copy it. (see pic)

  • Hit your windows icon on your task bar and type: cmd. It should bring up a selection for the command prompt. Hit Enter to open a command prompt.

  • In the command prompt type: cd then a space and press Ctrl V to paste in the address of the folder that you copied from the step above and hit Enter. It should now be displaying the full path to that folder.

  • Now in the command prompt type: esptool.exe -p COM# erase_flash and hit Enter (replace # with the com number that you saw from the install.wled.me page)

  • Once it’s done erasing type: esptool.exe -p COM# write_flash 0x0 esp32_bootloader_v4.bin and hit Enter

  • Once it’s done type: esptool.exe -p COM# write_flash 0x010000 WLED_0.13.3_ESP32.bin and hit enter. When it’s done you are good to go.

  • Connect to the esp32’s wifi (SSID WLED-AP) and configure your networks wifi details.

So this is what I got after entering the command prompt, Im super lost here. I followed step by step my file looks exacly like the example shown

and now when I try and connect the window just spins on the connecting box

Not sure what happened with the first erase part, maybe there was nothing to erase.

The second part you did not change COM# to COM4 and you have three 4’s after esp32_bootloader_v4.bin

Try again and skip this step: ‘Now in the command prompt type: esptool.exe -p COM# erase_flash and hit Enter (replace # with the com number that you saw from the install.wled.me page)’

and remember to set your COM# :wink:

Still running into what appears to be the same issue of it failing. I’m seriously losing hope

Are you sure you did this step?

  • Open the esptool folder and put the downloaded esp32_bootloader_v4.bin file and the WLED_0.13.3_ESP32.bin file in the folder.

It says it can’t find the file.

I believe I did it correctly but I could very well be wrong. I clicked in the address bar to get the path and pasted that in the comand prompt.

Do the files need to not have the (1) and (2)?

yes have to get rid of the (#)

I’m sorry, but it looks like im still getting the same issue after renaming the files without the (#)

I do want to say I really appreciate your continued help on this. Without it I surely would have pulled my hair out by now. Im hopeful to find the solution and will continue to try.

Hmm, not sure. Do you have a link to the Esp32 you bought? If you bought it from amazon it should be in your orders list.

I just opened a new Esp32 external antenna version and I just erased, flashed bootloader, and flashed wled. Here are the screen shots of each part.

erase_flash:

flash_bootloader:

flash_wled:

this is the one I bought, I’ve had a feeling that it might be the chip itself, I’ve never seen the command prompt say detecting chip type after connecting

do you have one you recommend?

Popping in as it seems you’re getting pretty far down the rabbit hole of possibilities - with fair reason I might add.

Any chance you can step back and try a different computer altogether?
I’ve always had good success with install.wled.me via Chrome on a variety of devices.
Try simple first, with possible BOOT button at “the right time”.

As well for any device I’ve had, the only load issue(s) have been proper pin pull-up/down per specs (hold down boot button or equiv).
Not saying you don’t have a bad series of MCU’s, but my experience has been 1 is a random failure, 2 is very rare and 3 is unheard of unless the reviews most/all say “piece of junk”

Just my $.02

I appreciate it.

I have tried holding the boot button at multiple times, both buttons, etc but never get to a percentage, always failed to initialize.

I have tried two computers, I will say that I didnt update the drivers on the other because it was a collogues work computer and knowing the little I do about computers didnt want anything to happen and me break their computer. I’m fairly surprised there isnt a preloaded option

Thanks for popping in divsys. You surely know more than I do about all this and pretty much my next reply was to see if anyone else had any ideas.

Joseph,

I have 2 of those exact same boards and I had no trouble flashing those right from install.wled.me
No holding any buttons down or any of that, so it ‘should’ work.

There is also another person over on discord that recently bought those boards and they flashed the Sound Reactive version on it w/out issue.

Have you tried using your 2nd board? If not I would give that one a try. Also make sure when power is connected that the board is not touching any metal objects as that can short the board out.

When you click on ‘install’ at install.wled.me you should have a window that pops up that looks like this but with whatever com# your system chooses:

com

If you have other things pop up in there the pic above should help you to find the right one.

One last thing, From your amazon link you have the 38pin ‘narrow’ version boards right? Not the 30 pin.

I appreciate all the help, I did try the second board with the same results, I did get that window to pop up except it had something long the lines of “bluetooth (something)” com4. I believe I found a preprogrammed controller on amazon that will work for the time being, but I would love to figure this out and be able to use esp32’s in the future. Do you have a brand or retailer you would recommend?

Most any Esp32 should work. I know the ones you linked from Amazon work as I have 2 of them.

These work: https://www.amazon.com/dp/B07BK435ZW Though this board was harder to flash and required holding the button down at certain times. (not sure when or how long I just messed with it till it flashed)

https://www.amazon.com/gp/product/B09LMBX8WH/ work as well, but you will need an external antenna for them.

Prebuilt options I would look at:

I would download/install this driver, reboot your pc and try install.wled.me again
https://www.silabs.com/documents/public/software/CP210x_Universal_Windows_Driver.zip

Sorry for the constant questions at every step. So what do I click on to actually downloads/installs the cp210 driver?

No problem.

  1. Right click on the silabser.inf file (the highlighted one in my pic and select Install)
  2. Follow the instructions