Help installing WLED on XIAO ESP32C3

I am very new to programming field. Have 0 knowledge. Bought this MCU for a macropad and realized it doesn’t have USB HID.
Then I came to know about WLED. But when I try to install it gives me error that ESP32C3 is not supported.
Is there any tutorial/ step by step guide to make it work?
I like this project and looking to put this MCU for good use than throwing in a bin.

Firmware for C3:

Info: Install WLED Binary - WLED Project

The link is not working. I have a Seedstudio Xiao ESP32-C3, i´m having issues trying to install WLED on it.

1 Like

Yes, that’s old. Try here.


I tried if one of the versions fits my ESP32C3, unfortunately I get this message…
is there a hint?

greeting Normen

yes press download and do not do save as

1 Like

Hi all, I have tried with the latest one, but still getting errors: Invalid Header

… and when I check,I cannot see any AP.

Anyone with same experience please? (Confirming I am trying it on the C3 for now and not the S3)

Thank you

I was able to correct that behaviour by pushing the “BOOT” button as I was plugging in the board to the computer. I was then able to flash the XIAO ESP32C3 without any error. WLED is now running on it.

Thank you and hope it helps other too

1 Like

Perfect! Thanks so much.