ESP-01(s) 8266 Dramas

Pulling my hair out at the moment. I am not sure what could be going wrong I have a mix of ESP-01s and ESP-01. I Have had great success with the firmware everything worked as it should. I needed another 3 so got these from my supplier.

I Flashed the firmware but constant connection issues very unreliable so I figured it was a bad batch of ESP-01s. I have ordered some more from somewhere else and waiting on those to turn up.

In the meantime, I see that a new version of FW was released so decided to upgrade the current fleet, the same issue! I figured it is a firmware issue so rolled it back to a version I know works ok version 0.13.0-b4 problem remains :frowning:

An un(re)flashed version of 0.13.0-b4 still works fine but anything newly flashed has the same flakey issue. Looking at one light (with glitter running) It looks like the ESP is crashing as the light sequence pauses every 30 seconds or so. I connected a 2A power supply and the issue remains (30 pixels), I also added a 4700uF cap (all I had laying around) across the power supply with no improvement.

I have been using to flash using:

sudo python3.9 --chip esp8266 write_flash 0x0 WLED_0.13.0-b4_ESP01.bin

I have also tried erasing the flash then flashing again.

(ubuntu) I have also used a windows tool to do the same but have the same issue. I guess I want to find out what is causing the issue like logs or something?

Appreciate any suggestions.

Can you build yourself?
This PlatformIO env will help you get back on track unless ESP01 themselves are bad.

board = esp01_1m
platform = ${common.platform_wled_default}
platform_packages = ${common.platform_packages}
board_build.ldscript = ${common.ldscript_1m128k}
build_unflags = ${common.build_unflags}
build_flags = ${common.build_flags_esp8266} -D WLED_RELEASE_NAME=ESP01
  -D RLYPIN=-1
  -D IRPIN=-1
  -D BTNPIN=-1
lib_deps = ${esp8266.lib_deps}

Also check ther is no -Dregister=and -Dno-register in platformio.ini file in the build_flags.

If you want PIR swich on GPIO3 uncomment usermod as well as Auto Save.
These settings will also allow you to OTA update ESP01 using 2-step procedure.

Yes and no :slight_smile:

I have the environment set up and I add the example you provided but when I go to the UI all of those options are still available. Is that right? I don’t know a lot about this part of it. I do get a new firmware.bin in .pio and I wrote that.

When you refresh PIO environment you should see new option esp01_1m_full_usb (ant head icon on the left → refresh at the top).
Expand it and select build ot upload.

I added it to the list of default_envs and then it seem to generate it. It is smaller than the other builds so hopefully, it has done the trick.

I found out the issue, pretty stupid on my part. I was changing the AP name then rebooting. On the reconnection, my phone was caching the old name and I was connecting back to that. Once I removed the network from my list of wifi ap’s everything started to work.