ESP01 starting issue

I’m recently using ESP01 with lithium batteries
but I have a problem.
My configuration :
-9 leds ws2812 connected to a batterie
-Leds Data connected GPIO2 (with 330ohm resistor)
-And I’m using an LDO 3.3v for the ESP01.

When all connected, I plug the batterie, and the firsts leds are lighting white like a data issue.
But when I disconnect data, I plug the batterie and then I plug the leds data it works fine !
Do you know what I’m doing wrong ?

Little video to show you the problem : Esp01 issue - YouTube

Thanks in advance :pray:

I had similar issues which were resolved by omitting the resistor.


Thanks for your reply but no it doesn’t change anything.
I tried to power my esp01 with an ESP32 3.3v output and now it works pretty well !
But I use the exact same circuit as ESP32 instead of the diode (see picture). Does this diode can make an effect on the data ?

You may want to add a pull-up resistor (4.7k) to GPIO2 and GPIO0.
This will ensure proper boot sequence on ESP01.

WoW, Thanks it works well !
But now when I turn on the esp, I have my 2 first leds flashing white full bright for 0,5 second and then working well.

Is there a way to not have this flash at boot ?

Very likely, you’re seeing a boot string being sent out of GPIO2.
That’s built into a core part of the ESP code (not WLED) and not easily changeable.
Simplest solution is to use a different GPIO.

As @divsys says this is usually boot gibberish on GPIO2. Even is you use GPIO1 (next best candidate) there will be gibberish output.
GPIO3 can be pulled down (10k) but will limit number of LEDs used. GPIO0 is not recommended for LED output.
If you want good controller board (with included MOSFET for analog 12V LEDs) get an ESP01 shield from @srg74 . It includes pull-up resistors and level shifted output as well as 5V & 12V option.

Thanks a lot,
I tried different things and finally I found that there is a 13.3 version for esp01, and now I can use the gpio3 and it works perfectly !
No need to have pull up or pull down resistor anywhere, and the program start without flashing :partying_face::partying_face::partying_face: