Esp32-s3 devkit c

wanted to see if anyone has any success with getting esp32-s3 devkit c working here. Have several of these boards with different memory sizes and types. Build will sometimes load, but never seems to provide a working version of Wled. I am interested in these boards as I would like to run many of the user mods, and really need the extra pins these boards provide. Prebuilt binaries wouldn’t really be a help as customization is the goal. Guess I am struggling most is getting the bootloader to work properly. Any help that can be provided would surely be appreciated

I have tested S3 but i only have Lolin S3 , the way it worked every time is that the initial flashing is done via esptool as detailed in discord by this post ( just look for softhack posts in beta-testing channel if you cant access the link ) Discord
After that used this site to compile on github and tested usermods and OTA worked ( most of the time ) . At the moment using audio and animatrix usermods and it is stable but still not as good as a normal esp32 but i guess that would change in the future