Esp8266 d1 mini WS2812 weird behavior

Hey, I recently bought a WS2812 lightstrip (This one). When powering it, only 4 LEDs are lightning up:

I also tried powering it with a power supply with the ESP8266 and using only the power supply - Same result, that means it has nothing to do with the data send by WLED. Other lightstrips work with this board as expected.

I don’t know if this is the right place to ask.

Does anyone know what might cause this behavior?

Almost looks like some pre-defined segment or mapping is coming into play.
Can you change colours or affect the 4 LED’s in any way or are they random?

Is this a fresh install of the MCU?
Make sure you’ve defined the strip type as WS281x in LED Preferences.
Might be worth a factory default or full reload of the MCU.

Hey, it’s a fresh installation, the lightstrip is defined correctly. Also, the LEDs are always the same color with any effect/color combination

Can’t tell from the photo, but guessing you’re inputting data to the DI end?
Is this a new strip, has it ever worked?
Are you powering up from a good enough 5V supply?
Any chance you accidentally hooked a 5V strip to a 12V supply (even briefly)?

The lights are hooked up to the 5V pin of the esp, the Data flow is also correct. It’s a brand-new strip and never worked. I have already successfully used other strips with the exact same board and pins.

If that board still works with other strips, I would say a bum strip.
What happens if you just power the strip - don’t attach the board/data at all?
If you get the same lights, the strip is burnt, time to move on.

Ok, seems like it’s burned. Thanks for your help!