ESP8266 requires reset before WLED will start

I have noticed this issue in newer batches of ESP8266’s (and only in the ESP-12E variant):

When power is introduced, WLED does not boot automatically - and consequently. the blue LED on the 8266 does not light. However, when the reset button is pressed, the blue LED lights and WLED boots.
Immediate subsequent power cycles work properly. If power is removed for several seconds and then reapplied, the issue occurs again.

I have tried several different batches of ESP8266’s from different vendors. The ESP-12F do seem to work while the ESP-12E do not.

I have used hundreds of the 12Es in the past with no problems - is anyone aware of anything recent that might be causing this issue?

@jasonsomers Welcome to the discousion

Ddi you check the install page // and install from this page direct online via browser

the older versions 13/ 14 seams not to show this issue

I only use the WEMOS D1 ESP8266 mod shield this does not show this behavior

@Aircoookie2 this needs to be invested

check the bootup voltages on the pins that require a special state during bootup. Or just add external resistors to see if it changes the behaviour.

Fresh installs using exhibit the same problem.
I have tried my own compiled 13.3, 14.4 and the new v15 beta. All exhibit the same problem.
I am not using the Wemos D1 mini. I am using the ESP12E/CP2102 like those found here:

I have tried several different sources, and it seems that all of my new orders of these boards have this issue. The batch I received several months ago works fine.

My guess is that something changed on these and I was hoping that folks in this community might already know what it was.

Which pins require a special state? Again - I haven’t needed to do this before on these boards.
I see notes about GPIO1 and 2 needing to be pulled High to boot. Would this conflict with anything in WLED if I have my two outputs assigned to these GPIOs?

No one has else has this issue?
I find that hard to believe…

Turns out that adding a pullup resistor to GPIO1 resolves the issue for me.
While I know this isn’t a WLED problem, it seems to me that if many folks end up having this issue it would be a concern.

1 Like

Good evening, I have just read your message, but not having much knowledge of electronics, can you explain your solution to me a little more so as not to have to do an RST to start editing. Sincerely.

I wired a 1K resistor btw VIN and GPIO1 (TX) pins on the ESP8266 and that worked fine - although we should NOT HAVE TO DO THIS if the controllers were designed properly.

Hello, thank you for your help, I applied your modification, it works very well. Thank you.

1 Like

it depends on the board you use, this is normally taken care of, as you said. There are many badly designed ESP boards out there.
Also: you should pull it to 3.3V and not Vin, if you do that with a small enough resistor, it will kill your ESP.

the datasheet states: “U0TXD (GPIO1) should not be pulled externally to a low logic level during the powering-up”

in a more readable version than the datasheet, this is also stated here:

Thanks on the clarification with the proper pull-up voltage…