Finally I could flash all three ESP32 after USB Port change

Hi ! Just new to ESP and WLED but many questions.

I bought 3 AZ-Delivery ESP32. I could add new bootloader and 14b1 to device with esptool, the web interface keeps telling me it’s prepairing installation and got stuck there. Pressing the reset button for flashing didn’t help. With esptool it worked. Connected that to the web interface and it told me that the device is already flashed and asked me the local WiFi credentials. So far so good. I tried the second of the three, same as number 1, device recognized ESP32_ABCDEF but when I entered the WiFi credentials it got stuck at sending them to ESP32 it seems, waited several minutes if it may take longer than the first device. When I reload the page the device is not recognized and I have to erase and upload bootloader and 14b1 again. I tried the third device, same issue : I can upload bootloader and bin but as soon as I try to enter the WiFi credentials and send them to the device → blue circle of death.
Then I thought I can access the device via the WiFi AP or and enter them manually but no chance, I can see no new AP in my list and stops with a timeout.
Console is empty, no life sign.
When back on WLED firmware upload page it shows me the WLED_ABCDEF device name and asks me again to enter WiFi credentials…

I changed the USB port to 3.0 and both missing ESP32 wrote the WiFi credentials with no prob at all.
Why did it work once and then never again on the previous port ?!?!
Anyway, now I have three working boards.