ESP32 loads properly, but WLED-AP does not transfer to WiFi

I recently upgraded to ESP32 because my 8266s would not connect and I could get no pixels to light up. Now my roofline lights up, but I have no control. They are all different colors and pixelations. I have loaded WLED 12.0 on the ESP32s and WLED - AP will show up and when I enter in my network and password it will save, but it does not connect to the network and I still have no control of the LEDs. Looking for any help I can get

Watch your power connection to the ESP32, it needs to be solid.
USB connections can be questionable as the WiFi on those boards takes unpredictable spikes of current from time to time. That can drop the supply voltage to the point that the board registers a brown-out and resets.

If you have control when the ESP32 doesn’t connect to your home WiFi, then try shutting down (or isolate the ESP32 so it can’t see the WiFi) and connect via the AP. You could try the “Disable WiFi sleep” checkbox, that’s been helpful to me on occasion.

Yes, have th ESP 32s hardwired to my power supply. When they are powered I get the WLED-AP in my available wifi connections. But when I go there it redirects me to the WLED startup page, I enter my browser , password etc But when I do it says Client IP : Not Connected, then hit save and it will come back on with my appropriate browser and password when I go to the page again, but I still don’t have control. I have not been able to “discover” either boards with the app no matter what I do. I tried using the Mac address from each of the boards that I find in the WLED setup window, and placing those on the DHCP reservation list, placing them on specific IP addresses, but it just said device off line.
I have flashed both cards with WLED12.0 using ESP Home flasher and I can see that I have power to my lights (different colors and pixelations throughout the range) I have no control. Maybe I’m wrong but this feels like the problem is in the controller.

Also, I am using the 3.3V and ground on the board for logic level shifter and my pin is D2 or GP102. Anything else you think I should try?

Also, I cannot see the WLED devices (two boards) coming up in my network on my gateway for my router.

What type of ESP32 board have you got?
Are you powering the board via 5V or 3.3V?
There have been reports that the onboard 5V-3.3V conversion is weak on some boards (never seen it myself).

If you can get to the WLED-AP you can control the LED programming, just leave the WiFi entries empty and Save. Then you can go Back till you hit the main WLED GUI.

What type of router are you using?
Are you using DHCP for the board WiFi settings?

I would try one board at a time to simplify your issues.
Make sure you have the EXACT SSID correct, it is definitely case-sensitive “My-SSid” is NOT the same as “MY-SSID”. Ditto for password (of course).
Watch out for WiFi passwords with “odd” characters, if you hunt on the forum you may see some references.
If the router doesn’t show a connect attempt I’d focus on the SSID/Password settings.
If possible, disconnect the board from the strip and bring it near the router to eliminate signal issues and be sure the SSID is correct.

Should be pretty cut and dried, other than power and fumble finger issues, I’ve never had any problems connecting.

I am using an ESP32 WROOM and Im using a 60Amp 5 V power supply. The 3.3V output of the board is being used for my logic conversion and I am getting 3.3v from the board too the logic converter. Don’t know the type of router but I am using DHCP, no static IP addresses.

I will try one board at a time, I was actually thinking about that too as an idea. I am using the exact same SSID and password for my 2.4MHz wifi. I dont know if its making a connect attempt. But my SSID and password are only numbers and letters with no “odd” characters and I have literally tried this about 25 times, so I know its in there right (LOL) I think Im going to disconnect power to one board at a time and see if that sshanges anything. Is it possible to use a different p[in for WLED?

Pin settings are under LED Preferences.
You can choose any GPIO (less than 33?) not already in use .
What browser are you using to connect to the GUI?
I’ve had some versions of Apple devices (and others) try and “uppercase” the first letter of my password entries whether I wanted that or not.

Ok I’ve had it. I think I’m Going to switch back to
My ESP8266 boards. When I connect the 32s they do not have an internet connection but my said and password are entered correctly. However under my settings the work comes
Up With WLED when I’m standing at the board and I can change things but different lights come on and I still have no Control. I have a MAC and
No Way to flash with esptool the whole reason I
Was Switching from the 8266 was because my internet connection in the garage was spotty and I was told the 32 s were Better for internet discovery. Last year my system Worked perfectly with the 8266s and I just can’t get them
to connect to My network even when either board is powered it’s not showing up on the gateway for
My router. Any pearls of wisdom here. ???

Have you changed your router/WAP since last year? I’ve noticed WLED won’t connect to wifi networks that don’t support older 802.11b connections. My guess is that it’s between the older TKIP encryption vs. AES only encryption. When I toggle off the b support, they no longer connect, 8266 or 32. I haven’t done too deep of testing this suspicion yet though.

Also, check if your router uses band steering. This uses the same SSID for both 2.4ghz and 5ghz bands. It trieds to “steer” clients to the 5ghz band, sometimes even if they don’t support 5ghz like our favorite Espressif boards. If this is the case you will need to separate the two bands into separate SSIDs.

Wow. I went to bed fuming over this and I looked at my router again and I noticed that the way they put it in was all in CAPS. I changed it back to the way I had it and it worked. I have some segments but lit but I was expecting to replace section so that will be the easy part. Thanks for all the help

OK, First I want too tell you thank you for ll the help. I finally got the ESP 32 boards to be found on WLED-AP and my router, but I still had problems. I have actually switched back to the ESP8266 and both are discovered and on my network.

So my problem now is that I replaced a string of LEDs on my roofline because it stopped showing any leds and it now only lights up light blue. Im actually running a parallel string from the center eave of my house outward in both directions. The one direction with new light in place only lights up light blue and does not change to my settings in WLED. The other side flashes between the color selected and bright white. When I try not take it to a motion effect it just strobes.

The other part of this issue that not all of my strings are lighting up and seem stop at the same point down the chain of LEDs.

So why would one light do one thing and not respond at all to commands (other than on and off) while the other one changes and flashes since they are connected to the same control line.
My thought its that its a bad pixel somewhere or short, but that seems like it would have to be two bad pixels in the same area. I have set my LED number to 750

This whole system has worked for the last two years, so Im thinking its more of a programming issue (or at least I hope it is )

Any thought?

Glad you’re connected now at least!

I understand this has worked for you in the past, but you might find your debugging easier if you eliminate one of these parallel strands. Fewer overall variables to contend with, and technically these LEDs are not meant to be controlled in parallel like that.

Are you certain you have the correct LEDs specified in LED settings? How many LEDs are actually in these strings? Does increasing the length of your strings enable more of the LEDs that aren’t illuminating?

No I changed the LED string to 1500 out of curiosity and it did nothing. I started with the sides disconnected and still only got the new lights too light up in light blue and didn’t change is I changed to look at both.

With the 8266 Im assuming my pin assignment should be pin 2 for GPI02 and thats what I set it at. I could easily split them out into two different 8266 boards, but have never needed to do so. As far as the number, I think there is 600 in each string. I even tried to lower the LED number to 100 to see if I could control that much and I did not work either

What type of LEDs are you trying to control? To me, solid illumination that doesn’t respond to wled changes sounds like the symptoms of having the wrong LEDs specified in “LED Outputs.” Since you’ve changed your hardware around a bit trying to sort this out, is it possible the LED output got changed too?

Im using WS2812s and they all come from the same vendor. I verified the LED preferencess section of the WLED says WS281X and the output pin is 2.

For my esp8266 build, the default output pin was 2, but that corresponded to pin d4 on my board. Are you running the 32 or the 8266? Which pin are you connected to, according to the silkscreen on the board?

I’m connected to pin D4 and have the output pin set to 2 in WLED under led preferences

Alright, well it’s not that then! Sorry for all the questions :sweat_smile: Have you confirmed your level shifter is still working as intended? Is it feasible to remove the level shifter and try to control a short string, say 30 LEDs? Any chance you have a spare, known-working strip you could test on?

Edit: Does the mibehavior change if you lower your brightness too ~20%?

I am getting 3.3. V from the 8266 and then 5v out to the control wire. I. attached the new string to just the one side of the parallel strings and I didn’t have anything else connected and it powered up the light blue only

I think you have too many variables at play here to effectively debug through the internet. If bad diodes in your strips are a possibility, then no amount of fiddling will fix it until they are disconnected. If I were in your shoes, I would disconnect all your outputs from your 8266. I would remove the level shifter, connect a string of known-good LEDs, set your string length to 30 or less, and get to a point where you can reliably control that short string. This way we can isolate exactly where your problem lies, and then move forward with fixing it.

(If you are using a multimeter and measuring a constant 5V at the level-shifters data output then something is almost definitely wrong there. I don’t have much practical experience with them, but their output should theoretically be a PWM signal with a 5V peak. I think a multimeter should end up measuring an average less than 5V, since the signal is actually bouncing between 5V and 0V very quickly. Is the output from d4 on the 8266 a constant 3.3V? Or is it a constant that is less than 3.3V, or is it fluctuating?).