Change from ESP8266 to ESP32 not working

The best wishes for the new year!!!

I have 2 ESP8266 working perfectly controling 1200 LEDS. When with Xlights the LEDS stutters, so I was wondering if upgrading to ESP32 would solve this. (hopefully) Only when I connect the ESP32 boards the pixels stay white. (even if I change settings in WLED)

ESP 32 boards: ESP32-DevKitC-VIE ESP32-WROVER-IE 8Mb Flash
WLED: WLED_0.11.1_ESP32 (flashed with ESPhomeflasher and later with PyFlasher)

WLED is working and connected to home network and can be changed etc. with phone/laptop.
Wiring, I tried everything (literally) but started with D2. Can someone help me?

Is it the wrong WLED software, even if you can connect to it? At first I got 3 errors after flashing without holding the boot button and 0 with holding it during flash, both times the LEDS stay white. (and I could operate WLED with my phone)

The 3 errors:
Showing logs:
[22:56:21].pio\libdeps\esp32dev\LittleFS_esp32\src\lfs.c:998:error: Corrupted dir pair at {0x0, 0x1}
[22:56:21]E (59) esp_littlefs: mount failed, (-84)
[22:56:21]E (60) esp_littlefs: Failed to initialize LittleFS
Serial port closed!

Second issue:
I reflashed the ESP32 boards a couples of times I tried it also with Pyflasher, it performed without errors, now the AP is not showing anymore… :frowning: This is true for both boards.

I followed some steps after doing some reading…(installing ESP32 bootloader (wihout success, but after reinstalling WLED) I could see the AP again and connect to it…the leds stay white. (connected to D2)

Use GPIO16 instead of standard GPIO2

Thanks, should I also use the pin16 WLED bin? That one would not install to the boar. Many thanks, I will try it tomorrow, it’s locally 00:51 and I have to go to work tomorrow… :frowning:

Disconnect everything from your board and try to erase and upload GPIO16 bin file.


Thanks I tried a couple of times and ia am able to see the AP on both boards and i am able to connect. Only de pixels stay all white. (connected to 16) if I connect a couple of other strips they all remain off. (they all work with other boards.)

Hmm. Maybe you need to do a custom build for your board. First because it’s a wroover and second because it’s non standard 8mb.


I did some testing If I connect via USB power and flash WLED_0.8.6_ESP32_ledpin4.bin and conect the green to 4 it works, if I do it via 5V and ground the 5 volt light of the board lights up but the leds stay white and AP is not showing. Maybe I use the wrong power in of the board or maybe a “dirty” power suply? (the leds also pulse a little but and quite fast.

I have no experience in custom building, are there some tutorials or is i very difficult? (I thought i buy a "fast ESP32 board and would be set :slight_smile:

WIth WLED_0.8.6_ESP32_ledpin4.bin I have got both boards working, Why it doesn’t work (correctly with newer versions I don’t know. It only also works with USB power and not with external power. Does someone nows the “Normal way” of powering the ESP32, I have connected it now via 5V and gnd

Here is link to custom build for your board and pin16 try it

Thanks I’ve got the latest version working with pin 2, only when powered via usb, the discord link you’ve sent is not working? I feel like a total noob, but i created an account but cannot see the build board. Thnaks in advance, you’ve helped me enormously, now I “only” need to figure out how to power the board via external power supply.

As I see it now via documentation I only can power it via 3.3V in I believe, will check if I have a stepdown somewhere and test this.

According to your picture 5V pin is good to use. Unless your onboard LDO is not working. It’s easy to test. Measure voltage on your 3.3V pin while power from 5V. It should be 3.3V. But you can’t power your strip over board.

Many Many Many thanks for thinking with me!!!

All and all it was probably a dirty power supply which I am trowing out now. I tested it with a stepdown to 3.3V and separately powering the pixels and boards and it works, after reading your comment I re-attached the 5V and removed the 3.3V and it works like a charm! (with a good power supply)

In the end:
Flashed the latest version via ESP Home flasher (without touching any button on the ESP32)
Attached the data to pin 2
5V in to 5V and ground to ground

Happy camper here!! :smiley:

Now soldering it al to my christmaslight box and test if Xlights performs via WLED/ESP32 than WLED/ESP8266, on my 1200 pixels still hanging on the house… I really hope so.

1 Like

Additional info: When changing from ESP8266 to ESP32 nothing changed for me for the behavior of WLED, maybe a little more responsive.

When connecting it to Xlight it stutters the same or maybe more than the 8266, not what I was expecting.:slight_smile: :thinking: The solution for me (this was also already documented :man_facepalming: ) was: Disable WIFI sleep and use Unicast, but the best results came form disabling WIFI sleep. :partying_face: One ESP has 472 Pixels, the other has 947 pixels. I send data from Xlights with 20fps/50mS. I can still use NTP server time, without cause lag!!! All and all a great solution.:slight_smile: :hugs:

I only have some max white flicker comming from 1 ESP32, but maybe it’s because I didn’t use a resistor for the dataline. (The ESP8266 that was in this position performed excellent with WLED) (I have a pixel 4cm from the data out acting as a voltage shifter) or maybe that I one time connected it with a 12V adapter instead of 5V…I always laughed over guys how did that, now I am one of them :crazy_face:

Many thanks again to srg74 for taking the time to help a noob like me :smiley: . Now creating more pixelstrands/props/sequences for next year. And of course, WLED and this community rock!

I’m glad you sorted out your issues. Flickering happens because absence of correct shifter and long wires. Look at solution like this or QuinLed-Uno.
Resistor most likely you don’t need.