Odd WIFI problem

I am at a loss.
I have installed WLED, (I have the MAC address set to assign the IP from the router)
It connects to WIFI after a few second during setup, I set everything up, LED’s work fine. Everything is good. I can get to it with the app or directly using the IP address. Save settings, everything works.

Until I unplug it.
It won’t connect back to WIFI. I’ve tried changing wireless routers, moved the routers location.
Nothing seems to work. Only way I can get to it is reinstall and it connects fine.

What ESP board are you using (post a link if you can)?
What does your SSID name look like on the router?
Have you tried the “Disable WiFi Sleep” setting in Config->WiFi?

Do you get the WLED AP if it doesn’t connect to your router, ie. is WLED booting, but not connecting to your router?

The SSID name “AOL dialup”
I have tried the disable WIFI sleep also. no change.
I’ve also changed the AP settings on different times i’ve installed.
Occasionally the AP will show up when it’s not connected using the default setting. I can access it when that happens. Currently, it is not connected to WIFI and the AP does not show up.
I’ve also used 2 different ESPs… same result.

How are you powering this setup, does it make any difference if you try with no LEDs attached?
Not what you want in the long term, but it can sometimes isolate out power issues.

What version of WLED are you running BTW?
Is this your 1st go at these or have you done any in the past?

I’m asking questions to narrow the field as best we can, it’s not meant as any judgement on you or your gear (just so you know).

When installing, the usb cable… Even if after the install and I unplug it, and plug it right back in to the same port on the PC… it still fails to reconnect.
I have tried it with no LED’s connected. no change. The LED’s are powered separately anyway. (12V)
It has SR 0.13.4 currently, I tried 0.14.0 to see if that was the issue.

1st go with WLED. The only other change from the basic default settings is GPIO 16 instead of 2.
It just doesn’t make sense it works fine at the initial install but won’t connect once you unplug it.
When I did go into the AP, it showed it was not connected to the network.

1 Like

I’d definitely work from ver 0.14 (release).
If you get into AP mode, can you then config for WiFi?
What are you using to do the install, install.wled.me on a chrome browser?

I tried .14. same issue.
When I could get into AP mode, it shows the correct settings for the wifi. Still won’t connect. Even tried setting it with the static IP address. No dice.
Yes, used the install.wled.me on Chrome.

Have you watched the serial port to see any of the power up debug messages? Might be a clue there, and/or perhaps a full wipe and reload?

This shouldn’t be that tough…

I have not watched the port. I would need to look into how to do that.
I thought about a full wipe as well, what is the easiest way to achieve that?

I would also try giving your router a reboot.

There should be a checkbox for “Clean Install” which will wipe your previous settings.
The router reboot suggested by @Jinx is also a simple test.

You can watch the boot data by monitoring the serial USB port used to install the software with a simple terminal program (TeraTerm or some such).

I thought there might be another type of clean install. Every time I reinstall it, I do the “Clean install”.
I as far as rebooting the router, I can’t say for sure if I have done it with this particular router, but I have swapped routers and got the same result.

Also make sure your SSID and password do not contain any special characters.

nope. all letters for both.
I just can’t understand why it will connect fine when first installed… but not after it is restarted.

Tried a few more things trying to figure this out.

Removed the assigned IP address from the router so it pulls it from DHCP.
Changed the router name to get rid of the space.
Installed 4 different versions… no change.

Any other thoughts?

Try installing WLED and don’t setup your wifi config.
Power cycle the board and look for the WLED Ap from available wifi networks.
Connect to it and setup your wifi details. See if that happens to do anything.

Still no dice.
I tried an unused ESP32… same result.
The WLED AP shows up occasionally. When I do try to connect to the AP, sometimes it takes 7-10 times before it will actually connect. I tried also with the “always on” setting to see if the wifi had an IP address, said “not connected”.
What is strange is I can see that the router has assigned it an IP address but WLED will not connect, at least after the first run after the install.

What if you go at this from the opposite direction.
Turn your router off so there’s no chance of WLED connecting to anything.
Turn on WLED and connect to the AP.
Change the WiFi config to the wrong SSID so it can’t ever connect.
Restart your router and WLED and see if you can consistently get to the AP.
This doesn’t fix your WiFi issue, but it should let you know that WLED can be reliably reached via it’s AP.

If that works, you can try to bring your router back into the picture. I might try getting another router and set it up with a simple SSID and password for test purposes.

Also try accessing the device by it’s ip address and not with one of the WLED app’s ‘finding it’

So after multiple actual headaches trying to figure this out… it may have been the ESP32 itself.
I did try accessing it by it’s actual IP… no dice, tried pinging it also, no response.

I didn’t try the “wrong ssid” for that board. I ordered 2 more (actual espressif boards) and as of the moment, this first one seems to work. At least at the house.

Is there a possibility of it having to go through an access point that would cause an issue?
I guess I will find that answer out tomorrow when I take it down to the shop.
Thanks for the insight, hopefully this issue will be resolved. I’ll post an update.