Full white with analog RGB

I typically run my deck lights from a MagicHome controller but I’d like something a bit more configurable. Using the latest release (13.1, I believe) with an RGB node (not RGBW). Running on an ESP32. Output is defined as PWM RGB with 3 pins defined for each of four outputs. External power supply is used for power. The node has 3 wires, black, red, green, and blue. Black is connected to 12V on the power supply. R, G, and B are run through MOSFETs connected to Negative on the power supply.

While testing, each color works as expected but, when I set the color to full White, I’d expect all 3 LEDs to go full power to create the white color. Instead, I seem to get a light blue color, very dim. I’m not sure if this is a node issue, a software issue, or just something I’m doing wrong.

Any ideas?

Thanks for the help!

All three should turn on. Maybe you have a current issue (can’t supply enough)?

I kind of thought the same, but the power supply is a 29A 350W Meanwell so I should be good, especially for just one node at the moment. I’ll have to test the pins on the ESP to see what’s being sent when White is requested.

So, my understanding of how it ‘should’ work is correct? PWM RGB as the type and it just magically knows that it should send the signal to all 3 wires to make white?

Then maybe wires too thin.

No magic. :smiley: You can also use white-balance correction to shift it from warm to cool and back.

I would LOVE to see some magic! :joy:

This sounds like the same problem I am addressing. I see you never got a solution.
My ESP32 connected to WS2815 RGB string. Acts like the controller is subtracting for a non-existing white led. Doesn’t matter if you drive one or a hundred pixels, if you try and turn one white it will go almost completely off. Fairly sure the data is wrong from code, not power supply or color correction.

I should have come back and updated. So…in my case, it seems to have been an issue of not having a good enough ground. I was testing everything on a breadboard and it looks like the bus bar on the breadboard couldn’t handle the amount of ground required when all 3 MOSFETs were pulling (to make white). Once I moved the MOSFET ground pin out to straight ground from the Meanwell, it worked like a champ. I’ve since completed the box and all 12 MOSFETs (3 for each of the 4 channels) are directly tied to the Meanwell and I’ve seen no problems since.

As for the code, I actually just rolled back to the standard code base instead of customizing it and it’s doing everything I need it to. Hope that helps!

WS2815 is identical to WS2812 protocol wise. There is no problem in the protocol.
There is also no white calculation taking place with WS281X protocol. If you are using LEDs with white channel then you have an option to select how white channel behaves and if it affects RGB or not.
I personally have 2 strips of WS2815 (5m in length, 150 LEDs) and do not experience any problems with them. I can use white without any loss of brightness.

This leads to the following conclusion: either you set your configuration incorrectly (it would be nice if you could provide a screenshot of your LED settings page) or your LED strip is faulty.

I had a wiring error. Sad and embarrassing for a thirty year electrician.

We’ve all gone through that one. :+1: Gotta give you credit for owning up to it, though. Glad you got it figured out.

1 Like