GS8208 Addressing Issue

Hello! I tried search for “GS8208” on this forum to see if this problem has been reported, but found no result. I hope it is appropriate to report here.

I have a 12V GS8208 pixel string. Have an ESP8266 running WLED 0.13.1 and get them connected. To reproduce the problem with the following steps:

1: Go to LED settings, configure LED length as 1 (WS281x, Color Order: BGR - I tested the color order is corrected for this string)
2: Change effects or colors, no change on the first pixel. It seems WLED can not find the first pixel.
3: Go back to LED settings, configure LED length as 2
4: Change effects or colors, the first pixel get changed accordingly, but the second pixel not - it stayed on some random color even though at step 2 this pixel (the second one) is black (not lit).
5. Change LED length to 3. The first two pixels react when effects or colors changed, but not the third one.

And so on.

I tried skip first pixel, didn’t help.

Same thing happened when testing with F16V4 controller.

I wrote my own testing program with Adafruit pixel library, and the string worked as expected - I could change each individual pixel.

Really struggling. I knew there is an addressing issue, but don’t know why.

Please help. Thanks.

Under WLED what are you entering for the strip start and length #'s?

What protocol did you choose for the strip under WLED?

What did you use with the Adafruit library?
Can you your separate test program with NeoPixelbus?

For a 24 pixels string, I entered length 24. In term of the protocol, I chose ws281x. (GS8208 is considered a clone of ws2815).

Thank for looking into the issue.

I found out the problem through some more testing. Specifically I used segments to identified it was the first pixel that think its address is 1 not 0 - meaning it thinks there is a pixel ahead of it that is bad.

Then I went back to check the data wires and it turned out I mistook the one close to GND as D1 but it is actually D2.

The reason my test program worked properly is because I loaded it to my tester hardware where the connection is correct. And where the WLED running is a new box I just connected and the data wires are wrong (D2 is connected as D1).

Problem solved.