NeoPixel Ring + WS2812B... NeoPixel ring not rendering correctly

Hello, thank you for looking! I’m having a few issues I can’t seem to figure out.

I’ve got a strip of WS2812b, it’s 19 pixels long. At the end of the strip, I attached a 12 pixel NeoPixel ring from Adafruit for a total of 31 pixels. Both connected to an ESP8266. I’ve got power and effects for both of them, so success! Except:

  1. Even though I’ve got 31 total pixels, the last 3 wont turn on unless I set the total pixels to 34 in the LED Preferences. There is only 1 segment, and it is also showing 34 pixels.
  2. The NeoPixel Ring does not render the colors as I choose them. Instead, it will always show them in a “rainbow” color scheme. The strip works as intended.
  3. Creating a 2nd segment for the Ring still doesn’t fix the color issue nor the pixel count weirdness.

I really appreciate any insight that might help me figure this out. Thank you!

What model of ESP8266 are you running?
How did you flash the chip and with what WLED version?
Are both the strip and the ring RGB or is one RBGW?
Have you tried putting the two separate strips on different GPIO pins?

Thank you for the reply.

  • the 8266 is a KeeYees CP2102
  • I used ESP Home Flasher WLED version 0.13.0
  • The strip is RGB and the Ring is RGBW
  • I haven’t tried using different GPIO, it hadn’t occurred to me to do so.

I’m starting to see some possible issues here. Thank you for the insight.

OK, 1st issue is RGB & RGBW. They’re different protocols, one needs 3 numbers (RGB) the other 4 (RGBW) for each LED. You can’t mix them in a physical strip.

Move one to a different GPIO pin and WLED will create a virtual strip that has the same combined length, but let’s you use RGB for one and RGBW for the other.

When setting colours/effects you create separate segments for each and program as required.

1 Like

This is incredibly helpful, thank you. I will give it a try.