Wled Effects is not working

Hi, I started Wled today but I ran into a problem. My favorite April Night effect doesn’t work on Wled, and none of the effects work. The board I use: Nodemcu ESP8266 and the neopixel I use: Adafruit 12 with neopixel, thanks for your answers in advance.

Have you configured the WLED software to the correct data pin on the ESP8266? Have you configured the correct number of pixels? If not, the default of 30 should light up the first 30 pixels. What is the distance from the NodeMCU data pin and the first LED? Are you using a level shifter to boost the NodeMCU’s 3.3V output up to the 5V the Neopixel strip is expecting for the data signal?

Yes I’m configured led number and I’m connected D4 pin. But I’m using VV pin for 5 v. This is correct? (distance is 1 jumper cable)

Oh thanks, Wled Discord server is solved problem

Curious: what was required to solve it?

I forgot to select the palette effect from the Effects. But I was able to do this without choosing it at first.