WLED/Nodemcu - LED's not working

Hello all,

I’m new to WLED and I recently received the following:

NodeMcu: V3 with ESP8266
LED: ALITOVE WS2812B
Power Supply: 5v 20amp
*I can send links for the exact product if that helps

I’ll start with the obvious/key issues I’ve noticed. The wifi doesn’t work if I boot the NodeMcu while the D4 pin is connected (probably due to booting at LOW, but I don’t know how to change that). I’ve seen other issues similar online however they either have no solution or I tried and it didn’t work. I’ve used a multimeter on the other end of the LED strip and I’m getting around 4.9 volts so I don’t think its a current issue (could be wrong). Direct output from the PSU is 5.7volts.

Wiring: The LED and NodeMcu are connected to the PSU (NodeMcu Vin/Gnd). Not my original configuration, however, I tried to eliminate some jumpers.

I’ve tried 2 different versions of WLED but same results. I’m not using a resister, however, I’ve seen this work without the use of one. I’m hoping I’m overlooking something simple. The LED’s worked for my last project (running off a Raspberry Pi) so I wouldn’t imagine they are bad. I can test them if needed, I just would have to set all of that back up again. Any advice would be appreciated and I’m sorry if this is either a dumb or already answered question (I promise I did research first, lol)

Thanks!

You may be able to add a pull-up resistor between D4 and 3.3V to fix that.

I can’t remember is d4 the default pin usually used for leds? If so then I believe your wiring may be incorrect somehow. It should boot with no issues when leds are connected. Can you post a picture of how you wired your setup?

Here is a diagram of my wiring.