LEDs not powering up with either esp8266 or esp32

Just joined this community and a happy and grateful user of WLED. I’ve got two units working (esp8266 simply connected to individually addressable WS2812B strip) but whatever I’ve tried, even repeating the exact wiring, I’m unable to get other units to work. I’ve used esp8266 and esp32, with a variety of WS2812B strips, with a variety of wiring options. In all cases the WLED web app is accessible both as its own AP (http://4.3.2.1) and post-config on my home network. Its just the LEDs don’t light up at all. The power button in the AP works in the sense it turns the esp8266’s own blue LED on and off. Any ideas?

This is the basic wiring scheme: tried D2 and D4 for the data line.

Should work with D4 connected. What firmware did you use?

@gr1nch I am pretty new here too and something that was not quite clear when I started was that the “pin” field in the LED Preferences>Hardware Setup>LED Outputs references the GPIO pin, not the physical pin. So if you are using physical pin D4, you would put 2 in the “Pin” field because physical pin D4 is GPIO2, and, as it happens, physical pin D2 is GPIO4, go figure. :crazy_face: (on the ESP8266 anyway, on the ESP32 they figured it out and made the D numbering match the GPIO numbering). Also, and I may be speaking out-of-turn here and if I’m wrong someone can correct me, but the ESP8266 and ESP32 use 3.3v logic outputs, and the WS2812 strips use 5v logic. I used a logic level convertor to change the output level to drive my strips.

@srg74 thx for the reply. D4 is connected. I tried the latest firmware 0.13.0-b2, then reflashed with firmware 0.12.0 that works with identical hardware (two systems in the kitchen).

@Strider_Matic thx for your reply. I have two working systems with identical hardware not using logic level converters. Yup, the pin is set as 2 in WLED and the physical data connection is to D4 on the NodeMCUv3.

I’ve been testing voltages at various points in the circuit and all are ok, but I don’t know how to test the data connection :frowning:

Sometime esp8266 boards don’t like GPIO2 pulled down on boot. Use 10K resistor between GPIO2 and 3.3V. If you don’t like that change pin for anything else beside GPIO2.

@srg74 I’ve tried both, but to no avail. I’ve tested all the connecters, wires and controllers so it’s looking like a lot of my led strips are broken :frowning:

There is a chance that LEDs is went bad too. But you can try to cut first few LEDs from strip and there is a chance that next one is still working.

mein ESP8266 hängt noch an USB. Ich habe zum Testen den Ausgang 3V auf +5V am LED gelegt und GND auf GND. Die Datenleitung ist an D2. in der Datenleitung ist noch ein 470 Ohm Widerstand eingelötet.

Bitte entfernen Sie den Widerstand aus der Datenleitung. Verschieben Sie Ihre +5V von der Stromversorgung auf den mit VV markierten Pin und trennen Sie den USB-Anschluss. Verschieben Sie Ihre Datenleitung auf Pin D4 (GPIO2).

Hallo.
den USB-Anschluss trennen ? Ohne Stromzuführung klappt das nicht und eine externe Stromversorgung ist nicht angeschlossen. Ich habe trotzdem mal den Widerstand entfernt, die Stromversorgung auf VV gelegt und die Datenleitung (ohne Widerstand) auf D4. Es leuchtet nur die erste LED. Erst mit Datenleitung auf D2 funktioniert wieder alles.

Entschuldigung ! Ich habe verschiedene ESP’s und mich oben geirrt. Mein hier genutzter war kein ESP8266 sondern ein ESP32. Daher wahrscheinlich das Missverständnis zumindest mit dem Daten-Pin.

Thanks @srg74. By not cutting (yet!), but soldering connectors on the other ends, I’ve found some strips do work and some that don’t. So its nothing wrong with my WLED setup, even the (3V3-5V) level converters aren’t needed. So lessons I’ve learnt are:

  • be very careful when powering up prototype LED strips and esp8266/esp32 - you can destroy LED cells if not.
  • even brand new, unused LED strips may not be wired properly. Unsoldering the wires and connecting your own may be necessary.
  • even longish wires (around 1m or so) between the controller and strip may not need level converters at all
  • Create a fully working set of gear to act as your control setup
    With this control setup test all your other gear, changing just one at a time so you know definitively if that newly introduced component is fully working or not.
1 Like

Actually if your strip connected with short wires it should work. Problem is all addressable strips is 5V TTL and ESP boards is 3.3V CMOS logic. That causing all kind of unstable work. This is only a reason why shifter is recommended. Even all Chineese boards for LEDs strips control have shifters .

Testing and remaking the cables fixed the problem. The LED strip thankfully was fully ok. All working now.