Wled leds not responding to anything

I am freaking tired with this leds. Please help me.
Using Esp8266 controller and ws2811 leds. I have connected Leds data to the D4 pin and ground is common for both leds and controller.
Tried everything but still doesnt light up my leds.
Tried : -

  1. Pullup resistor to data pin
  2. external supply to esp
  3. different version of wled
  4. different controller i.e. esp01
  5. diffrent psu.
  6. gpio 16.
    Please help nothing is happening !!!

d4 on an esp8266 is normally gpio 2 not 16. On an esp8266 you should choose gpio 2 or 1.

Give that a try:
gpio2 = d4
gpio1 = TX

Tried Nothing Happening…

are you connected to the right end of the strip? Data only flows one direction. Do you have a pic of your wiring?

Its connected to Din in Proper Direction.

In image its 5v but i connected leds with 12v because ws2811 supports 12v only. And I have also Connected Common Ground for both.
And Data in D4, D3 & D0 tried.
I have Powered node mcu separately from usb.

I would try it without the resistor.
If you have 12v LEDs you should be powering them from a 12v power supply and the esp with 5v by way of a buck converter from 12v to 5v or with a separate power supply like you said.
How many LEDs are you trying to power?
How many amps is the power supply?
Did you turn off the brightness limiter or set it accordingly?
Can you show a screen shot of your LED Preferences page?

  1. Trying to connect 30 Leds.
  2. It supply’s 2A and checked with 4.2A also.
  3. Yes i do checked brightness limiter by on and off both.
    I have also checked With buck convertor also no response and about 100 times without and with resistor but still no response. Also Changed Led Preferences with 5, 10, 20 so on leds with different gpios.
    And One more thing when i set colour in wled app but it doesn’t change or turn on that time but, when i unplug the connections of led and then immediately plug it then its shows the previous applied colour with some flickering leds between with random colours and after that it wont change any thing.

hey ive got same issue but with a lamp i made . worked ok for awhile now one of the strips (made a 9x15 matric inside a ikea kadja lamp. ) is now doing random flickering. think it may be a power injection issue or data wire too long. but will try and see if bridging an earth from that strip to another ground…

Gonna have to experiment…
As for you. are you able to test your components with other chips …strips… …something as over as a faulty strip… or bad controller…
i had a strip with a faulty i.c on it someplace where when powered on the same random 4 pixels out of 30 lit up… even without the data wire connect… gace it to my girl for a necklace as that’s all it became… lol

process of hardware elimination… maybe…

Bro, I’ve also troubleshooted the controller. first of all i thought that my leds are also gone for a moment, but later i connected the leds with arduino and double checked it. And for the controller i have esp01 with buck convertor and esp8266. Troubleshooted the controller with relay controlling apps also nothings faulty so i am totally confused what to do…

ESP01 is tricky. Maybe @srg74 can help.

ESP01 is 3.3v based board IMHO, you must use a 1117 Regulator, if you connected
the ESP01 to a 5v, its probably dead already.

I have used a buck converter for 3.3v for esp01 so voltage regulator is not an option. bro i am totally fed up with this wled, i quit and i am going to throw this leds and controller to the dustbin and i wont try this wled shit again…

Used gpio5. Or put resistor between data and + (10kom)

tried brother its not working…
i dont know if my strips are broken or my controller bcz when i connect my strips to an arduino it lights on perfectly. when i connect esp8266 with other components such as relay it works fine but when i connect both strips and esp8266 it doesn’t light up and when i disable power supply of strips for a second and then turn on, strips lights up with earlier position where i left of.
So i am confused…

patience Jedi