LED Strip not working using esp32

Hardware :
WS812b 5v 16.4 ft 300 LEDS
ESP32 DEVKITV1
Power Supply 5V 30A
Software:
WLED
I can get the esp32 to communicate with the phone and/or the PC browser

I can’t get the WS28* Led to work
I am connecting the 5 v and ground to the LED strip front (arrow direction) and back (for power injection) and from the front connection to the ESP32. from the esp32 D4 to the data on the LED
I tried different Data Pins nothing works

ESP32 will have red light for power and blue light for Wifi

image1

Did you set WLED to use GPIO4 for LED output?
Are you sure you’re feeding the ESP32 output to the DIn line on the strip?
Why do you appear to have 2 connections to the strip, one hard wired and one via a JST connector?
You can feed power at 2 points, but data must go to only one - and it must be the correct one.

Yes, the WLED is get to GPIO4
Yes, The Gray line / Data Line is feeding from esp32 to the LED strip in the middle of the JST
The power is powering the LED strip and I am using the same power from the LED/JST to power the ESP32
Yes, I am feeding power from both points front and back of the LED strip. but the data is only front direction of the arrow.

Can you show a pic of your Led Pref’ page? Also are you sure your dupont jumpers are making a good connection not only in the jst but on the esp pins.

Yes, the Jumper has a good connection.
Attached is my Led Pref.

To verify that I have a good LED strip - I did do a a continuity on the 3 wires from front to back and all are good. so I assume the LED strip is good? or should I order a new Strip ?

How would I test the Data from the ESP32 ? can I check for Voltage or anything to make sure data is going through the LED strip?

Try setting the length of LEDs to 50 and see if those 50 light up.

There is no way to test the data w/out an oscilloscope.

Dumb question, but you did press the power button on the top left of the GUI to turn them On?

Jinx , it is not a Dumb question because I ask my clients that often :slight_smile: but yes I toggle it on and off .
I did change the LED to 50. no luck
I tried to flash the ESP to and older version but still no luck .
I think I might have a bad set of LEDs I will try to get some new ones

You could cut off the first LED and see if it works from the 2nd one. Maybe the first one is bad.

It would also be a good idea to have one of those cheap mass market controllers for testing the strip.

Here is a bare bones one that comes with a 150 led strip for $14 and change: https://www.amazon.com/gp/product/B09738FNN1/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&th=1
Just wire it to your power supply and plug the LEDs into it and see if they work. Then you know the strip is good.

This one has more options with a remote: https://www.amazon.com/BTF-LIGHTING-WS2812B-DC5-12V-Wireless-Controller/dp/B01DC0JKGY but has a barrel jack connection for power.