ESP 32 wiring WS2812B

Hy guys,
i’m new here i’m trying in all methods to make this work. I already changed esp32 with another one the same result, i changed also with a d1 but nothing. The problem is that te led don’t switch on. Seems thats the wiring be fine because if i try to switch power on or power off from web ui i see the blu led on esp32 shutting down and start again when i start it. In this photo you can see i also try to connect all ground in one. Nothing change. Someone please could help me? Shared Public - Google Drive

Try changing your config in WLED to drive only 10 LEDs to start (just for testing).
That way you won’t run into issues with the Automatic Brightness limiter.

Make sure that you chosen the correct GPIO pin in WLED to match what you’ve connected on your ESP32 board. Checkout Randomnerd Tutorials to see what GPIO matches the numbering on your board.

Thanks for your reply. I can confirm that also with setting some led instead of all I have the same result. The pin is the correct one because I just check it. Any other ideas?

I see a few things here that may or may not be the issue.

I would connect the Esp directly to the power supply and not be trying to power it off the far end of the LED strip. This is not likely your problem currently but down the road it very well may ‘brown out’ due to lack of current.

Your wires that you have soldered to the strip look to be stripped quite long and maybe they have touched one another and shorted out? This would likely kill at the very least first LED in the strip (maybe more).

As divsys said, try a small # of LEDs (10) in your settings as 850mA is for sure not going to power 200+ LEDs.

If you could post a good pic of what pin you have the data connected to we could verify if you have the correct one set.

One last thing make sure you have your data connected to the correct end of the strip. Data only flows 1 direction and there are some manufactures that are putting their jst connectors on the wrong ends. If your strip happens to have an arrow on it, that is likely the direction data needs to flow (regardless of how they have DI/DO listed). Example: The ones from this company are backwards. The 16x16 matrix they sell is backwards as well.

  • If you are sure your gpio is correct I am leaning to either you are connected to the wrong end or your wires touched and killed one / some LEDs.

Thanks all for contribution, very appreciated.
I just try like @Jinx says and i take just 7 led from the other side of the strip and try to do the same.
Things that i try:

  1. Connect the little 7 strip led like the long one, also with ext power adapter
  2. Connect the little strip without external power
  3. Configure only 7 led on the wled configuration.

In all this 3 cases i have the same issue. I don’t know if it is very clear on the images but i have 1,3,4 on and the others off. Anyway 1,3,4 always on because i cannot control them. The light is white.

I do a video with the simple connection of the 7 led strip.

Seems that the data cable is not connected correctly or something like this.

I create a new folder with the new things here: Shared Public - Google Drive

Again thanks for contribution.

Something very strange

In your video in LED Preferences you have the gpio set as 2. On the Esp32 you are connected to D4 and that is gpio 4. You need to change gpio 2 in the LED Preferences to gpio 4. :wink:

Here is a list of the pins for your board

I try it both. Same results.

Send from iPhone

Apologize for brevity and typo error

Hey guys thanks for your support.
New update
I do other test based on your information and I think the problem was that I use data on the wrong side. Now seems everything OK.

Thanks a lot

1 Like