WLED on MiniKit ESP32MH-ET: led strip off

Hi all,
I’m trying WLED on this MiniKit ESP32MH-ET:

flashed with WLED_0.12.0_ESP32.bin firmware, with a BTF-LIGHTING Strip Led WS2812b.
Which PIN should I use as Data/LED pin?
I already tried IO2 and IO16 with no luck, ESP32 module is up & running but the LED strip is off.
The other half-ish of the same led strip is working with WLED 0.12 on NodeMCU without issues.
Thanks for any tip.
Cheers,
-f

Should work fine with GPIO16. How do you flash your firmware?

By ESP32 module up and running, does that mean the WLED-AP came up and you are able to connect to it or does that mean the lights on the board are blinking?

Do you have a common ground between board and strip?

How are you powering everything?

I’ve always had good luck with the ones that actually have MH-ET stamped on the back side and the TTGO T7 mini (same form factor). But a lot of us have had problems powering some of these on the 5v pin. The ones that have issues seem to work fine on USB power or the 3V pin.

using esphomeflasher

the first one: WLED is connected to wifi and I can manage it through the web console
the board is blinking as well once power on

yes, see the wiring below

5V10A is powering both ESP32 and led strip, below the wiring:

Now I take the 5V for ESP32 directly from the power supply, 3V pin means a different wiring I suppose.

It sounds like you have half your string working? Is this correct? If so, make sure you have configured your “LED Settings” correctly - by default wled is set to 30 LEDs. To control more, you need to tell it how long your strip is.

You mentioned :

Any chance you’re not sending data to the correct end of this strip?
From what I tell in your picture, you’re taking output on GPIO2, is your WLED configured that way or have you moved to GPIO16 as suggested (GPIO2 is connected to the onboard LED I think).

Is it possible to swap boards temporarily to try and prove both strips will work?

1 Like

My mistake, I did not make myself clear :slight_smile:
The led strip counts total 300 LEDs:
I used 112 of them for the other WLED project (with NodeMCU),
188 residual LEDs are for this project with MT-ET board.
Just to clarify that these LEDs with this power supply, with another ESP board, works perfectly.
Right now, no one LED is working on MT-ET.

Good question :slight_smile:
In fact, I connected the end of the strip because wired as like the start… Should I use the cutted side?

Look at the strip where the LEDs are - you should see small arrows pointing towards one end of the strip. Those arrows represent the direction data must flow in. If you try to feed data backwards (compared to the arrow) you will get the behavior you’re experiencing now.

Good to know, I’ll check in a minute.
What about the +5V and GND pins? Are they follow the same rule?
Maybe right now I’m using the wrong side for power, also.

Power is common along the whole strip.
As long as you apply +5V to the 5V pin, and Ground to Ground you can do it anywhere on the strip.
Data has a start and end point so they give you arrows to show you where it starts.

Update:
same scenario using cutted side for LED Pin, leds off.
So I tried the led strip with another board - Lonin32, this:

(again WLED_0.12.0_ESP32.bin firmware)

Lolin32 board powered on with USB,
using GPIO2 as LED pin,
led strip powered on with the strip end,
it works.

Any other suggestions with MT-ET board?

My last idea is to make sure you’re using the same pin your settings are configured for. I only have first-hand experience with the 8266, but I know that the silkscreen on the board doesn’t necessarily line up with the gpio pin name (on my 8266, GPIO2 is labeled as D4). I’m guessing the 32 could be similar. Try to get a pin out for your exact board from where you purchased it and make certain your settings match your wiring.

So you’ve proved the strip is good.
Are you still using GPIO2 on the ESP32MH-ET?

My next suggestion would be to reload the board with ESP32 - 0.13.0-b4 and then connect via the AP. Set the board up for a different GPIO or verify that you know what pin you’re connecting to with the MH board (load the “Blink” code and try different pins).

I suspect your board works but you need to verify the board labelling matches what you think the GPIO’s are.

1 Like

I doublechecked everything and soldered again, from scratch.
Using IO2/GPIO2 as Data PIN, all seems working fine.
Maybe it was a false contact at first try.
Sorry for the noise, thanks for your help!

I know the effect well, it regularly involves Murphy, Gremlins, The Render Gods, and other imaginary creatures - ignore them at your peril…

Glad you got it working!

2 Likes