No Data Signal to LED Strip


New to WLED but have been running LED strips using FastLed for years without burning the house down so I an not a total NOOB.

I ran across WLED last week in a Reddit post and am excited to use it as I was working on a project to make my current Teensy/FastLed installations wireless by using an ESP32 but I see WLED is very feature rich and has a great GUI.

Problem I am having is I am not getting a data signal out of my ESP32 GPIO2 Pin and over to the WS2012B strip of LED’s to make them go blinky blinky to impress loved ones and neighbors.


  1. ESP32 Development Kit (board) Version 1 purchased last year
  2. Flashed WLED Version 0.13.9-b6 onto the ESP32 and can pull up the WLED app on both my PC and iPhone. WLED-AP broadcasts fine.
  3. A 3.3v to 5.0 Volt Logic Level Shifter - even though the LED strip is only 12" from the ESP32
  4. A strip of 60 WS2812B LED’s
  5. ESP32 and LED’s powered by an independent 5V 15A power supply.

Troubleshooting done:

  1. All breadboard connections successfully tested using an Ohm meter
  2. Power voltages checked okay at 3.3 or 5.0 volts at each connection using a Volt meter
  3. Checked that all Grounds are tied together properly using an Ohm meter
  4. Tested the LED string successfully using a Teensy running FastLED
  5. Eliminated the Logic Level Shifter from the circuit by connecting the LED data wire directly to the ESP32 GPIO2 pin. Unsuccessful.
  6. Unsuccessfully switched the Data pin on the breadboard and within WLED from GPIO2 to GPIO23
  7. With GPIO2 selected for data within WLED; Pin GPIO2 on the ESP32 produces zero voltage. Tested by measuring voltage between ESP32 GND and GPIO2 pins
  8. Have made sure the WLED is turned on within the app.
  9. With WLED running I plugged the LED data wire into every ESP32 PWM pin with no success.
  10. Rebooted the ESP32 with the LED data wire disconnected to GPIO2

Can someone suggest what I may have missed in my troubleshooting? This is is real head-scratcher.

Here is a pic of my breadboard setup with the LED data wire connected to GPIO23 on the ESP32

How did you flash the ESP32?
Try the web installer:

Make sure you’ve set the string type to “WS281x” in LED Preferences.
I use those exact ESP32 boards all the time with no issues.
You could try GIPO4 in the LED Preferences which maps to D4 on the board.

Your setup looks OK, should be very cut and dried.


I flashed the ESP32 twice. First tried the Web Installer. No errors reported during the upload. Then thinking there might have been an un-reported error; I used to erase memory and then re-flash the Boot Loader and app.

String type is set to “WS281x” in the LED preferences.

Moved data wire connection and app settings over to GPIO4 and that works!

Thank you sir!

You are most welcome, for future reference the web install has been very effective for a variety of devices.

Have fun with WLED, let us know how it goes :sunglasses: