Heat sensor

So currently running my Christmas light display… I’m in New Zealand so It gets pretty warm here at Christmas being our summer.

My little wemos are siting in boxes around the garden with some PSU… Now even tho its hot, we also get heavy tropical rain… So there all IP 65 boxes

I do worry about hot there getting, I guess for other user it’s how cold there getting…

Was wondering if there was a way to add a heat sensor to monitor what’s going on in the box.

Hey! I would highly recommend a DS18B20 temperature and the Temperature usermod at WLED/usermods/Temperature at master · Aircoookie/WLED · GitHub

This will give you a temperature reading in the info page of your WLED instance.
Have a merry Christmas season!

Is there any chance this could be permanently added to wled…

There a number of boards out there adding that sensor l?

That is available in Temperature usermod.
You need to compile yourself or use bin from @srg74

1 Like

Any link to that file?

1 Like

Is it working fine with esp32?

Does this work with Ethernet.

Yes, though on ESP32 there are occasional hiccups.

1 Like

Yes, just select binary with Ethernet and Temperature usermod (if there is one).
You can also compile sources yourself.

any particular issues?

how to push this as to Homeassistant? I have already installed mosquito mqqt broker. What next?

Method is simple

On wled

  1. Config.
  2. Sync interface
  3. enable mqtt. In Broker you will use the IP address of the mqtt broker, in case you are using mosquito broker on Homeassistnat, input the IP address of Homeassistant.

For username and password, if MQTT broker is already setup in Homeassistant
integrations | mqtt | reconfigure mqtt server
just copy and paste the MQTT username and password into the respective fields.
On Homeassisstant

  1. setup Mosquitto broker Home Assistant MQTT Install and Setup - A Beginner's Guide - YouTube

  2. Add the following code to the configuration.yaml
    new code

# wled temperature        
    - name: "wled temperature"
      state_topic: "wled/123xyz/temperature"
      device_class: "temperature"
      qos: "0"
      unit_of_measurement: "°C"

Old code

sensor wled temp:
  - platform: mqtt
    name: wled temperature
    state_topic: wled/123xyz/temperature
    device_class: temperature
    qos: 0
    unit_of_measurement: "°C"    

123xyz(it can be anything phrase of your choice) is the topic which must be the same on the HA and wled
To confirm connection use mqtt explorer. http://mqtt-explorer.com/
Status should be online, time should be most recent.

@srg74 there is a bug with this configuration, it loses connection with mqtt broker. and to fix that you have to reboot wled, followed by changing the brightness. which restores the mqtt connection.

There is no bug. Works as expected on my end.

which display is supported with wled? LCD 16x2 Character-Based LCD Display — ESPHome and OLED display SSD1306 OLED Display — ESPHome

1 Like

For those looking Discord
SSD1306, SH1106 I2C or SPI

can’t we update @srg74 firmware via homeassistant?

the above Homeassistant configuration code should be updated as follows

# wled temperature        
    - name: "wled temperature"
      state_topic: "wled/123xyz/temperature"
      device_class: "temperature"
      qos: "0"
      unit_of_measurement: "°C"

Unfortunately only stock (no usermods) firmware can be updated over HA.

used @blazoncek firmware 0.14 for the esp32.

For SH1106 Display

Dallas D4 pin.

WLED_0.14.0-bl0_ESP32_display_and_dallas_sensor_usermods.bin (1.3 MB)

Use default setting. working.