Multiple Outputs with ESP32 (2)

Hello

I need 9 outputs. Whenever I program more than 6 outputs, I no longer get to the LED settings page.

Larsen

What also matters is how many LEDs per pin. See here.

Yes, it says that my ESP32 10 pin can do what but not.

PIN 16 = 120 LED
PIN 17 = 75 LED
PIN 18 = 120 LED
PIN 19 = 95 LED
PIN 21 = 120 LED
PIN 22 = 76 LED
PIN 23 = 120 LED
PIN 25 = 95 LED

When I enter this, I no longer get to the LED Settings page. All other sites are working properly.

LArsen

What version are you running?
As you start to add more LED’s you should see memory usage go up.
What’s the used/total reading as you lose the settings page?

What if you add less(or more) LED’s per strip, do you lose settings with too many pins or too many LED’s?

It doesn’t matter how many LEDs I add at 8. it is only shown a white page. All others continue to run normally. The strip is also controlled correctly. Shows all effects and colors correctly. You just can’t change or adjust anything anymore.

Larsen

LED memory should be fine, looks like 59KB left to go.

The Filesystem looks a little small to me although you’re not showing huge usage (yet).

How did you originally load that board, did you work up (OTA) from older versions or load directly to 2109220?

Many people (including myself) are running happily on current dev builds. I have most of my boards on 2110110 v013.0-b4 and show a filesystem of 1507kB.

Might be worth a reload from scratch to see if it helps, [https://install.wled.me/] has worked well for me.

Ok I have to switch to a replacement board. Otherwise I will turn off the light in my son’s nursery. ;-). In my experience, it doesn’t matter, the result is the same.

image

image

I created the 8 with 95 LEDs and the side is white :frowning:

He’s already creating the segment, but I now have 8 segments.

Larsen

Weeeeelllll,

I just reloaded an ESP32 Doit-Kit board from scratch using install.wled.me.
Comes up with a 1507kB Filesystem.
Added 9 strips of 10 LED’s each using GPIO’s 16,15,14,13,5,4,3,2,1.
Can still access the GUI and/or setups without problems.

I’m not saying there aren’t potential issues lurking (there probably are).
You might want to try and build up from scratch and add LED’s until it breaks.

It’s still a little odd that your filesystem comes up different than mine - I see your Environment shows
esp32 v3.3.5-1-g8c43024c (0)
My Environment is esp32 v3.2.3-14-gd3e562907 (0) with a Filesystem of 1507kB.

Where did you get the .bin used?
How did you physically load that new board, what program/app/physical connection did you use?

So I have it now via https://install.wled.me/
made. Also went without problems. He immediately recognized the USB with the board.

I take off my hat. With this version I can create all pins !!! :pray: :pray: :pray: :pray: :pray: :+1: :+1: :+1: :+1:

Great, you can pickup 2110110 from the drop-down in

https://install.wled.me/

Worth it in my guesstimation.
The only issue I’ve ever had with the web install is needing to hold down the Boot button to start the install.

Glad it’s working…

Agreed. 0.12 has some bad bugs.

Good Morning

Unfortunately I couldn’t continue testing yesterday. This morning I first put on 8 strips, which worked. But when I put on the 9 stripe, all 9 stripes no longer work. Unfortunately, deleting the 9 strip doesn’t help either. The board only works again after it has been re-flashed.

Larsen

Just loaded my test board with your strip/pin/length settings.
I still have full control of the board after all strips are enabled.

If you’re loading from pre-saved JSON files, make sure there are no embedded errors.
Either check the file (especially for extra white space) or load manually.
Both the config and settings files are susceptible to errors.

I still suggest you move up to v0.13.0-b4. As mentioned, v0.12 has bugs and you can easily pickup v0.13 from the web install. Definitely reload the board from scratch, something in your version/config/presets is causing a problem.