NTP Time

Am I doing something wrong that my NTP time won’t sync?

The year/month is always wrong, either 1970 or 2106:

I have tried to put in a UTC offset, which works, but by the morning the time is completely wrong again. I thought it may be a connectivity issue because I think ive set it up correct, but even with a booster 10’ away the Hours/Min are way off in the morning.

I have never been able to get the Year/month/day correct.

Try pointing it at your home router for NTP services.

That’s a good idea - I’ll give that a try tonight! Thanks!

Hey @huggy-d1, I tried various addresses for NTP services but still can’t seem to get things set up using the app. I used my home router address, google ntps (8.8.8.8 & 8.8.4.4) and a few other ones that I have found online, but nothing seems to get it remotely close.

I’ve reflashed my esp8266 from v10.0 to v10.2 and still have issues. I’m actually using 4 esps on my house lights, and I can’t get any of the esps to work. After the flash the time shows 1970, and after I enter an ip address, the time always seems to go to 2106-02-06, 23:30:00 - doesn’t matter what time of day.

I tried putting an off set in, cause I don’t really care about the date. But even with an offset, the time drifts by the morning.

Just curious if you have any other ideas.

DrZzzs posted a YT video over the weekend about configuring WLED. He has a small section where he configures NTP. Perhaps locate it and fast forward until you find that spot in the video and see what Dr Zzzs does differently.