Sending E1.31 when in AP mode may not work

This is to document a behaviour I observed yesterday.

When sending E1.31 data to WLED, it works fine when both WLED and sender are connected via a WiFi access point. When sender connects to WLED directly, not.

  • WLED on ESP8266 d1 mini
  • LEDs are SK6812, but that probably doesn’t matter here
  • 40A 5v power supply, using the first SK6812 as level shifter
  • WLED Version 0.9.1
  • Sender : a python script using https://pypi.org/project/sacn/ , using the simple send example with unicast (entering the IP of WLED as target, not multicast), running on Windows 10, Python 3.8.2

Observation:

  • Both WLED and sender connected to same WiFi AP (proper Unify WiFi hardware) - works like a charm (ping, wled web interface, E1.31)
  • WLED not connecting to WiFi but opening own AP: ping works, WLED web interface works, E1.31 not)

I will let this stay here for others as a warning and also change the E1.31 wiki page to share this observation, pointing to this forum entry for more info.

1 Like

Hi! I can confirm your observation, WLED does not initialize the E1.31 interface in access point mode. AP mode is primarily meant to try out effects and setting up the device, ongoing operation should ideally be in station mode. I might consider making E1.31 available in AP mode though as it could be useful for a portable FX installation.

3 Likes

Hi @Aircoookie. It is fine as it is! E1.31 is intended for larger installations and something “thought through” usually involving more than one WLED. Station mode is fine for E1.31 for ongoing operations.

I would not change that. It’s a waste of time. I documented it in the wiki - fine with me!

Portable FX… intuitively, I would tell WLED to connect tethering to my Android phone’s AP and write an Android app for portable FX … but I wonder if it’s possible to write apps that can talk to a device connected to the AP (I never progammed an Android App).

When you mention portable FX I am thinking along the lines of “Burning Man Costume / Wearable / ArtCar” setting. Intuitively, I would go for a portable WiFi station, because debugging is so much easier. I could connect to the station from my Android or Laptop to debug, and hope that both WLED and the E1.31 Signal giver are also able to connect to the Wifi Station. Again, I end up that E1.31 in AP mode is not necessary.

1 Like

Sorry if I’m necro-ing. But which is worse, necro-ing an old thread, or starting a new one about an old topic?

First I want to make it clear I am in no way complaining about anything. But, I personally would find it a benefit in having E1.31 accessible while in AP mode. In no way a deal breaker, as Leobard mentioned I can just make my phone a hotspot, and if it’s just too much trouble to add, then don’t worry about it. But if it’s relatively easy, I think it would get some use.

No worries at all - necroing is posting an unrelated or tangent comment in an old topic. If the topic of the comment is spot on and the thread is still relevant (in this case it is - still no E1.31 in AP mode), that is a lot better than starting a new one even though the old one is about exactly the same topic.

Back to topic - seems like E1.31 can be enabled in AP mode with just a single extra line :slight_smile: Will give that a try.

@Aircoookie

I completely agree with @Shoopity, I am actually looking for such an exact portable FX solution.
My question to you is, have you tried this yet? If so, is it available in current releases (v12 or v13-b2)?

EDIT: Works for v13-b2 for me