White Channel on Nightlight

I have a strip of RGBW LEDs (SK6812) that I’m using to make a sunrise alarm. I’m using the nightlight function to customize the sunrise transitions. I want to do 3 transitions in sequence

  1. Red (255,0,0,0) @ bri:1 → Yellow (255,255,0,0) @ bri:128
  2. Yellow (255,255,0,0) @ bri:128 → White (255,255,255,0) @ bri:255
  3. White (255,255,255,0) @ bri:255 → Bright White (255,255,255,255) @ bri:255

1 & 2 work fine, but 3 doesn’t. Here’s my code. Anyone have any idea what I’m doing wrong?

	"n":"Sunrise (3)"

And for what it’s worth, I’ve tested and eliminated a few possibilities.

I can use the sliders to manually change the white channel and see the change on the LEDs, so I know the proper signal is being sent.

I have looked at the JSON output for the slider in both positions and verified that the only difference is the white channel at 0 vs 255.

I’ve tried the effect with all three night modes ( nl.mode ) and no difference.

Just a wild guess on my part, but #3 is the only one that uses the W channel.
I would experiment with setting #2 to max out at 240 brightness and start #3 from there and see if you can get up to 255, but include the W channel as well as the RGB.

I’m guessing the W channel might not be handle the same way as RGB.

Might also make sure you don’t have any of the “Auto-calculate White from RGB” and “White Management” settings enabled