WLED SR cycling effects issue?

0.13.3 and version of WLED Sound Reactive, I’m trying to use a button to cycle the effects.
I have noticed that after a few times of pressing it it starts to bypass sound reactive effects and starts calling only the non sound reactive ones.
This happens whether I use the default short button 1 setting or if I create a macro (FX=~) and call it.
The only way I’ve found to fix it is to manually call up a sound reactive effect, and then start using the button again.
Do you have any ideas to solve?

That is just going to cycle through all effects and then jump to the beginning of the effects when it reaches the end. Presets can be iterated with upper and lower bounds. But at least according to the documentation, effects can not be bounded. You could create a preset for each of the SR effects you’d like to cycle through that instead of all effects. I you wanted to iterate through presets 1-30, PL=~&P1=1&P2=30 or in JSON 1~30~

actually the effects don’t cycle in order but randomly, and the strange thing is that after about ten changes it seems to become stuck on the effects that don’t sound reactive…
I knew the macro for cycling the presets, but if it worked well the preset would have been less complicated

I think that is a shortcoming , demo mode is practical and would be better if that could be tailored to effects type if it is audio reactive or not . There is a way to download sorted presets and playlists in MM but still would need a lot of presets . We used this for random effects for demo mode {“seg”:{“id”:0,“fx”:“r”}} but like you the effect type can not be controlled but would be nice if the api call could be edited to include group of effects . Might be an extra flag to be added to indicate if the effect is SR , 2D …etc

Another work around is to be able to call an fx directly from playlist without using ps but that is not possible with playlist at the moment but could be a good feature request

After several investigations I realized that the problem is the following:
whether you use the standard button to cycle the effects or use a preset like FX=~ or FX=[effect number] when you recall an empty position (in FX.h) the cycle remains locked.

(e.g. “48” or “53”)

1 Like

Marvelous Finding … I too have the same Problem when cycling thru presets , Any Fixes??
what i tried is created two presets like FX=~3 and FX=~-2 and created a playlist in repeated mode with these two presets… It works pretty well 90% of the time , but again gets stuck some where else …I think best Solution would be officially filling or removing the gaps/ Emptly slots …

Gaps were introduced by SR team to allow adding new core effects without affecting effects introduced by SR team.
Unfortunately effect cycling expects consecutive effect IDs and when it encounter a gap it no longer works correctly.

With 0.14 this was made even worse by removing certain old effects. If you wish you can file a bug report on Github.