WLED verliert die Verbindung im ioBroker

Hallo zusammen,

ich habe mir auch ein Projekt (Garagentorbeleuchtung) mit einem LED-Streifen (WS28128B) realisiert.
Angeschlossen ist der LED-Streifen an einem WeMos D1 mini pro mit aufgespielter Firmware WLED und
angesteuert wird das Ganze über meinen ioBroker auf einem Raspberry 3B bzw. manuell bedient
über die App per iPhone.

Es funktioniert alles wunderbar und ich bin wirklich begeistert, allerdings habe ich
folgendes Phänomen / Fehler:

Nachdem das System dann einwandfrei in Betrieb ist, kann irgendwann der ioBroker den LED-Streifen
nicht mehr einschalten und es sieht so aus, als wäre die Verbindung unterbrochen
(und kommt dann auch von alleine nicht wieder).
Dies tritt nach unregelmäßigen Betriebszeiten (ich schätze so ca. nach 1 - 4 Stunden Betrieb) auf.

Auch wenn ich dann manuell im ioBroker versuche den LED-Streifen einzuschalten (in den Objekten
den Zustand “on” manuell auf “true” setze) wird dieses true dann kurze Zeit später rot angezeigt
aber der LED-Streifen bleibt aus.

Wenn ich in der App auf dem iPhone dann das LED-Bad einschalte (oder auch über den Browser)
leuchtet es sofort und läßt sich einwandfrei ansteuern.

Wenn ich dann den Adapter im ioBroker stoppe und wieder starte funktioniert üblicherweise
alles wieder (eine Zeit lang) einwandfrei.

Was mache ich falsch bzw. was kann das Problem sein?

Weitere Info zur Situation bzw. was mir auch komisch bzw. unerklärlich ist und was
ich schon alles versucht habe:

  • Die WLAN-Signalstärke vom D1 mini pro wird in der App mit über 90% angezeigt
  • Als Firmware hatte ich anfangs die Beta-Version 0.13.0-b2.
    Hab zwischenzeitlich die Version 0.12.0 drauf.
    Verhalten/Fehler ist aber bei beiden Versionen identisch.
  • Wenn der Fehler auftritt wird in den Objekten bei WLED im Wifi-Ordner immer noch angezeigt,
    daß der Streifen online sei.
    Auch in den Adaptereinstellungen wird bei der IP des WeMos D1 Mini bzw. eben
    des LED-Streifen dieser als “connected” mit dem grünen Punkt angezeigt.
  • Wenn ich versuche den WLED-Adapter im ioBroker neu zu starten muß ich den Adapter
    stoppen (über das Pausenzeichen) und wieder starten (über den Play-Pfeil).
    Um einen Neustart über den Kreispfeil beim Adapter zu erwirken muß ich mehrfach
    (meist so ca. 5 mal) auf den Kreispfeil klicken/drücken damit er einen Neustart macht.
    Bei allen anderen Adaptern auf dem ioBroker erfolgt dies bereits nach dem ersten
    Klick auf den Kreispfeil.
  • Den WLED Adapter habe ich auch schon mal komplett gelöscht und neu installiert.
  • Versuchsweise habe ich auch schon einen zweiten LED-Streifen an einem Wemos D1 mini
    (keine pro Version) parallel mit angeschlossen.
    Dieser zweite Versuchstreifen funktioniert auch einwandfrei allerdings tritt hier auch
    der identische Fehler auf, daß nach einer gewissen Zeit der zweite Streifen auch nicht
    mehr über den ioBroker angesteuert werden kann
    (über die App geht auch dieser dann noch einwandfrei einzuschalten).

Ich bin sicher nicht der Fachmann im Bereich ioBroker aber bisher habe
ich noch alles zum Laufen gebracht.

Aber WLED bringt mich an meine Grenzen und ich wollte LED-Band nicht wieder
ausbauen müssen, da es nicht dauerhaft funktioniert.

Ich bitte um Eure Unterstützung bzw. Vorschläge und bedanke mich schon mal herzlichst im Voraus.

Hallo,
mir ist klar, dass dieser Post schon eine Weile her ist. Leider habe ich genau das gleiche Problem.

Allerdings bin ich einen kleinen Schritt weiter gekommen. Der Verbindungsverlust zu ioBroker entsteht durch einen Reboot des D1 mini. Nach dem Reboot ist dann der Effekt Solid(0) geladen, insofern man nicht anderes eingestellt hat. Versucht habe ich es mit verschiedenen ESP 8266 Platinen Sonoff SV, NodeMcu V3 und D1 mini. Bei dem Sonoff SV bin ich auf den Reboot aufmerksam geworden, da das Relais beim Booten geklickt hat.

Ausprobiert habe ich dabei fertige Images und auch mit Atom kompilierte Versionen. Egal. Immer wieder das Gleiche.

Zur Zeit bin ich auf der Suche nach der Ursache für den Reboot. Dabei bin ich auf den nervösen Reset Eingang der CPU’s gestoßen. Angeblich zu beheben mit einem 10 Kohm Widerstand gegen die Betriebsspannung und einen 100 nF Kondensator gegen Masse. Zur Zeit warte ich noch auf die entsprechenden Bauteile. Weiterhin habe ich die Stromversorgung der CPU und der LED’s getrennt. Jeweils ein Netzteil (nicht vergessen die Masse Leitungen zu verbinden!). Hilfreich ist ebenfalls nahe der CPU’s einen ELKO zur Stüzung der Betriebsspannung (2200 µF sollten reichen) und ebenfalls einen 100 nF Keramikkondensator zu verwenden.
Darauf gekommen bin ich, weil sich teilweise der Absturz bzw. Reboot provozieren läßt, in dem man Verbraucher wie Licht oder andere Gerätschaften, ein- bzw. ausschaltet.

Momentan habe ich es so gelöst, dass die WLED Instanz aller 2 Minuten neu gestartet wird. Nur dann sucht WLED wieder nach den CPU’s! Im ioBroker auf Expertenmodus schalten, danach die WLED Instanz klicken. Nach unten gehen dann sieht man weitere Einstellmöglichkeiten. Unter Anderem kann man dort einen Neustartzeitplan erstellen. Der Datenpunkt “online” ist nicht wirklich hilfreich, da die WLED Instanz nicht wirklich mitbekommt, wenn sich ein Adapter verabschiedet hat. Schade.

So. Ich hoffe ich konnte ein wenig weiter helfen. Wenn die entsprechenden Bauteile eingetroffen und verbaut sind melde ich mich.

Google Translate:

Hi there,
I realize that this post was a while ago. Unfortunately, I have exactly the same problem.

However, I have taken a small step further. The loss of connection to ioBroker occurs when the D1 mini is rebooted. After the reboot, the Solid (0) effect is loaded, unless otherwise set. I tried different ESP 8266 boards Sonoff SV, NodeMcu V3 and D1 mini. With the Sonoff SV, I became aware of the reboot because the relay clicked when booting.

I tried finished images and also versions compiled with Atom. All the same. The same thing over and over again.

I am currently looking for the cause of the reboot. I came across the nervous reset input of the CPU’s. Allegedly to fix with a 10 Kohm resistor against the operating voltage and a 100 nF capacitor against ground. At the moment I am still waiting for the corresponding components. I also disconnected the power supply for the CPU and the LEDs. One power supply unit each (don’t forget to connect the ground lines!). It is also helpful to use an ELKO near the CPU to support the operating voltage (2200 µF should be sufficient) and also to use a 100 nF ceramic capacitor.
I came up with this because the crash or reboot can sometimes be provoked by switching consumers such as lights or other devices on or off.

At the moment I have solved it so that the WLED instance is restarted every 2 minutes. Only then does the WLED search for the CPUs again! Switch to expert mode in ioBroker, then click the WLED instance. Going down you will see further setting options. Among other things, you can create a restart schedule there. The data point “online” is not really helpful because the WLED instance does not really notice when an adapter has said goodbye. Too bad.

So. I hope I could help a little further. I will contact you when the relevant components have arrived and installed.

Hallo,

noch einmal. Eine Sache hat sich mir nicht erschlossen. Die ausprobierten Platinen Sonoff SV, NodeMcu V3 und D1 mini funktionieren in meinem Wlan mit Tasmota ohne Abstürze. Laufen also völlig stabil! WLED macht sporadische Reboots?

Bei mir läuft ein Mesh Netzwerk von AVM (Fritz!). Was passiert eigentlich, wenn der WLED Client versucht den Repeater zu wechseln? Richtig! Die Verbindung zur WLED Instanz bricht ab. Die WLED Instanz verliert die Verbindung zum Client. Weg ist er! Da die WLED Instanz nur beim Start nach Client’s sucht, ist der Client nicht mehr verfügbar.

Nun ein völlig neuer Versuch. Ich habe mit einem ausrangierten Powerline Repeater FRITZ!Powerline 540E, ein eigenständiges 2,4 GHz WLAN generiert. Und? Seit 4 Stunden keinen Reboot und keinen Verbindungsverlust!

Allerdings erschließt sich mir der Reboot an der Stelle nicht? Bis jetzt läuft der Testaufbau völlig stabil.

Lassen wir es mal ein paar Stunden laufen! Ich melde mich noch einmal.

Google Translate:

Hi there,

once again. One thing did not open up to me. The tested boards Sonoff SV, NodeMcu V3 and D1 mini work in my wifi with Tasmota without crashes. So run completely stable! WLED does sporadic reboots?

I run a mesh network from AVM (Fritz!). What actually happens when the WLED client tries to change the repeater? Right! The connection to the WLED instance breaks off. The WLED instance loses the connection to the client. He is gone! Since the WLED instance only searches for clients when it is started, the client is no longer available.

Now a completely new attempt. I generated an independent 2.4 GHz WLAN with a discarded FRITZ! Powerline 540E Powerline Repeater. And? No reboot and no loss of connection for 4 hours!

However, does the reboot not reveal itself to me at this point? So far, the test setup has been completely stable.

Let’s let it run for a couple of hours! I’ll get back to you again.

Hallo,

bis jetzt läuft alles stabil!!! Firmware Problem?

Ich lasse den Testaufbau laufen und melde mich morgen.

Google Translate:

Hi there,

so far everything is stable! Firmware problem?

I’ll run the test setup and get in touch tomorrow.

Dieses Forum ist Müll, weil man nur maximal 3 Antworten generieren kann. Machts gut!

Google Translate:

This forum is rubbish because you can only generate a maximum of 3 replies. Take care!

Ein neuer User kann nur ein Bild hochladen?!

Google Translate:

A new user can only upload one picture ?!

Schließt diesen Post! Ist ja nicht der Rede wert!

Google Translate:

Close this post! Is not worth mentioning!

Ich habe keine Lust mich hier irgendwie nach oben zu arbeiten. Game over!

Google Translate:

I don’t feel like working my way up here. Game over!