Wled working but W2812B led not working

the led on nodemcu esp8266 is blinking when i turn the power on and off from the interface but WS2812B led strip does not respond at all (I tried with 2 different nodemcu, same result)

I have the same problem with DigUno ESP32. Configures network and app works. No response by the LED

How are you powering the nodemcu?

Does your 5v supply have enough current for the led?

nodemcu gets its power from usb, but led gnd and nodemcu gnd are connected.
power is enough.

can anyone help

It is a bad idea to power a nodemcu using USB AND use an external 5V supply at the same time.
Use the 5V supply to power the NodeMCU and the strip and keep the usb disconnected while the 5V supply is turned on.

It has been known to burn up a USB port on a PC.

I edited the connections like this, the usb cable is no longer there but the result has not changed. LED does not respond

thank you to everyone who helped. I found the problem, I connected the leds in the opposite data direction, completely due to my distraction.

When I reviewed your pretty picture of the device wiring layout, I verified the LED strip ► was in the correct direction. I am glad your physical wiring matches the planned wiring and it works as expected too!

thank you