WS2811 and NodeMCU v2 (ESP8266) fried

Hi, I have problem with NodeMCU v2 and WS2811 leds.
I used two NodeMCU modules and they blew up in the same way (the light on the module won’t turn on and esp is warm in touch). First module worked for couple of days, and then fried. I didn’t saw anything wrong with circuit, so I ordered new module. I flashed wled on it and connected board to the circuit, then again the NodeMCU blew up, but immediately not after a while.

I don’t know if i did something wrong or the modules were bad. I attached schema to this post.


PS: English isn’t my native language, and if this isn’t right category correct me.

Before connecting up ESP, measure voltage from step-down voltage converter.

Verify the voltage is within tolerances of the ESP module being connected. This usually means +/- 10%, but it might be something like 4.9 - 5.1VDC. It depends on the ESP module (NodeMCU or WEMOS D1 Mini for example may have slightly different requirements).

Once you know the voltage is correct, measure it relative to 12V supply common (ground), and relative to the step-down device’s - (common) output.

Then, measure the voltage between 12V P/S Common and the step-down device - (common) output.

That last measurement should be extremely close to 0VDC. If it is not, connect a wire between the input and output common on the step-down device.

If everything is measuring up properly, perhaps the connection on the LED strip is bad. If it is covered with heat shrink, measure the resistance between all 3 leads - one pair at a time. They should not read close to 0 Ohms on any of the 3 readings. If they are, you need to remove the heat shrink and repair the solder connections for the bad pairs.

It sure is a lot to do before connecting up the ESP. However it is worth it to find the root cause of any wiring potential problems while the ESP is completely disconnected.

1 Like

Ok, so I measured up voltage and it’s fine.
12,11VDC from power supply and 5,09VDC from step-down converter.

I think my led strip is bad/shorted because data line (middle wire on the strip) is shorted.
I cut off one segment, soldered wires and tested rest of strip on my Arduino UNO (not with wled flashed), worked fine. Then I connected strip to new NodeMCU and it blew up :c, so I connected strip to UNO and it almost fried (leds on board were on, but no power was connected, only data pin and GND).

I really don’t know what am I doing wrong. Now I have 3 fried ESP and one left that’s working (not fried and not connected to my leds). I don’t wanna fry last ESP. Maybe my led strip doesn’t like NodeMCU’s? hehe

You could try using a separate USB 5V supply for the MCU and send only Ground and Data to the strip.
Hook up 12V power independently to the strip.

You could also add a level shifter to act as a data/voltage buffer.

I ordered new led strip along with some other parts and I’m searching for cheaper ESP’s.
NodeMCU v2 is around 22 PLN + shipping. Maybe I will buy NodeMCU v3, that is 16 PLN in a electronic store nearby. But v3 is bigger than v2 and I will have to measure if it will fit in to my case.
I will be adding level shifter and some fuses, to protect things and maybe new case.

For now thanks for help! :slight_smile:

If you are only using one strip per controller you could use an ESP01. Only 8PLN each if you buy 5.

1 Like