WS2815 + Lilygo TTGO 3.0 Produces only flickering

Hey everyone, this is my first post here, probably not the last. A few weeks ago I learned about wled and it fascinated me. I wanted to try it out, so I ordered an athom controller, connected one of my strips and it was amazing. I’m going to use that athom in a project, but I’ve wanted to jump deeper. I’ve ordered three of those battery powered ESP32s and got them few days ago. After some troubles, I’ve installed wled onto one of them (v14) and got it connected to my wifi. After some soldering I’ve connected my wires as shown in this video. Only difference being that I powered my ESP via USB/Battery and not the power supply. That results in the ground wire coming from the PSU connecting with the backup and ground wires of the WS2815, the live wire connecting the PSU and the strip and the data wire connected to one of the GPIOs of the ESP. When I power the whole thing on, I get flickering, and I have no control over the strip from the ESP. I will attach some photos and videos to illustrate everything better. I know the soldering is quite messy, but it was my 3rd attempt and I couldn’t be bothered to be patient. The first 2 attempts were way cleaner, but produced the same result.

When I’ve tried to use the athom using only the data wire from it, I get the same flickering and lack of control as well. That tells me that the issue is that the controller has no control over the power of the strip, but since the WS2815 is 12v, I don’t see how my esp would control the power. Also in the video by Chris. it looks like it works perfectly.

1 Like

Here are the images -

I don’t see a ground return to your controller. Without this your data has no return path.


That’s my bad, I didn’t think about that… I will add it and post an update in few minutes.

Thank you very much @Adled, that was the solution… You saved me my sanity.