4 strips of led wont light up

I have 4 strips of leds all are the same WS2812B Addressable 300 Pixels RGB LED Strip Light 5m/16.4ft and when i change the count of leds to 300 1 set comes on, next 600 another set on, 900 and now they all go off.
Im using a nodemcu, 5V 60A DC power supply.
What am i doing wrong?

Any advise for this new guy?

If this is not the right place to post please direct me to the correct spot.

Thank you,
mrggutz

Start with one strip and make sure it’s working. After you can connect one by one and change quantity of LEDs in settings.

1 Like

Also, you need to be power-injecting along the way.

1 Like

Thank you both for the response’s.
I have made sure each strip light’s up like asked and they do.
Next I hooked up one strip to power and nodemcu and set led preferences to 300 and they came on, nest I added another strip and change led count from 300 --> 600 and both strips came on, next added the 3rd strip and added a power as well and changed 600 --> 900 and nothing happened they all stayed off. On the 3rd strip I ran a power line back to my power supply. I went into the wled config and change the led count from 900 --> 800 and bam I have lights.
Also when I added the fourth strip and changed count to 1200 (it said to keep at 1000) nothing happened, if I lowered the count to like 970 some came on but not all.

Are there other setting I need to adjust maybe?

LED count is 800
Maximum current is 1012 mA

Thanks in advance,
mrggutz

Something is not right in your setup. Please see max current for your setup. One LED is consuming max 60mA and you stating that your max current for 1200 LEDs is only 1012mA means every LED receiving less than 1mA which is definitely is not correct

Hi!
Please turn off the automatic brightness limiter in LED settings :slight_smile: This is the culprit here since it tries to limit the overall current to 850mA.

2 Likes

@Aircoookie is that a hard-coded limit within WLED? Is it something that can be changed using a platformIO compile time override, like -D HARDCODED_AMP_LIMIT 1100 ??

Man thank you for the advise.
I turned off the automatic brightness in led settings and they all lit up!

Thank you all for the help.

2 Likes

There is ABL_MILLIAMPS_DEFAULT in const.h. I can add #ifndef to it which would make it possible to set in pio. That said, this is not a hardcoded limit, but only a hardcoded default :slight_smile: You can always change the mA value to limit to in LED settings (I recommend setting to the power supply rating, and if 40A+, turning it off completely).

1 Like

You’re welcome! You might be wondering why this feature is there in the first place, there are a lot of novice users who do not appear to know it’s a bad idea to connect 300+ LEDs directly to the 5v pin of the ESP powered via USB, and thus burn it up. This saves them from having to buy a new unit (and potentially an electrical fire)

1 Like