Only 28 max leds light up

What am I doing wrong? 5V 5A power supply powering a 96led 1m strip and only max 28 leds light up. See picture attached.

I flashed WLED to Nodemcu and this seems like some sort of a communication or connection bug.

When I repower the setup, only the first led lights green. When I try to change anything with the WLED app, 28 leds go white. After that I have no control of the strip.

Just ruled out a dead pixel. Turned the color selector to white and set maximum brightness in WLED App and now 48 leds are lit white.

A setting somewhere I’m missing?

I think all you need to do is move the data pin on the nodemcu to the opposite pin header, same relative location from the end.

Reflashed the nodemcu and now all but 8 leds work and the strip can be fully controlled (except the 8 last leds). Tried to supply power to the other end of the strip as well, but no help.

Have you tried it without the resistor on the signal line? I had all sorts of weird problems when I had a resistor in line that disappeared without it.

You changed the default LED count to something greater than 30, right?

Yes, tried without resistor and have set the nr of leds to 96.

That is very strange. You could also check the Segments tab and make sure the stop LED is set to 96, but other than that I’m out of ideas…