Only 6 (5) LEDs on and segment0 reset every boot

Hi guys,

my proeblem with WLED is that every time I start that controller, it’s only 6 (5) LEDs lighting up.

My Setup:

WLED 0.9.1 on an nodeMCU v3 with WS2801 LEDs.
50 LEDs mounted on TV.

sha1: 73e967c214a533a4b99b9c5170e10be59938c23a

The LEDs are good. When I just cabled the controller to the strip with GND,CLK,DATA all LEDS (powered by separate PSU [3A 5V]) light up.

When booting (powering) the WLED controller only 5 LEDs light up and in settings there is segment0 woth 0 to 6. WHY ?
In the settings I set the correct number of LEDs (50) and thats saved, even on reboot.

I want to use this strip with WLED as well solo as in combination with Hyperion (libreelec) as ambilight.
[There is some future plan to use it in Home Assistant, but not in that moment]

What do I have to configure to make that work? What am I doing wrong about those segment or why is my WLED not using all 50 LEDs?

Really hoping to get help here, as the project seems to me very satisfying.



do all of your LEDs light up if you change the stop point to LED 50 in Segment 0?
If yes, you can save slot 16 in the Presets tab and set 16 as the boot preset in LED settings.

Normally segment 0 should always initiate to the LED count, i don’t know why that doesn’t happen in your case. Maybe doing a factory reset in Security & About Settings could also help.

Hi Aircookie,

thanks for reply. If the controller is up it shows segment 0 with 0 to 6 LED although 50 LEDs are stored to config. When changing it manually under “Segment” menu there is no change at all.

I tried setting slot16 to be the boot preset and configured some segments there, but still no change.

Will try the factory reset that you mentioned and then come back at you.

Thank you very much for that awesome project you are doing here.

What is even really crazy is that those 5 LEDs that light up are changing “randomly”, not really randomly I think but to a certain degree. :astonished:

Is your ESP’s 0V and LED strip 0V electrically connected (bonded)? If not, please find a way to bond your commons. That may just make you smile if that’s the problem.

No thats not the problem. They were connected all the time. BUT as Aircookie said factory reset seems to do the thing. So now I have multiple segments including all 50 LEDs. :+1:


Is there anybody that uses WLED flashed device with Libreelec (Hyperion) over serial connection?
I really have problems with that and get no connection, although all LEDs are good now and hyperion service is running.

Please help!

Do you mean WLED is connected via USB to your Hyperion device?
Adalight is the only USB protocol supported, with 115200 baud rate by default.

Hope you can get it to work!

Yes you are correct. The WLED (nodeMCU) is connected via USB Cable to my MediaCenter (libreelec on Kadash VIM). What is ment by this Adalight USB protocol? Is this something I have to configure in Hyperion config?


So when I start my libreelec device it powers my nodeMCU, during start the LEDs fire up a rainbow pattern and then go out. So there must be a connection/control of the ESP by libreelec (hyperion) right?Bit when I start a video there is no LED lighting up. What to do there? While nodeMCU is connected to Libreelec via USB, there is no control via Wifi possible, normal?

No, that is not normal, WiFi should always be available. I’ve had that issue too once, it seems to be due to interference…
There are two ways to get data from Hyperion to WLED for an ambilight, Adalight protocol (over USB) and UDP protocol 0 over WiFi.

Is this a common way over UDP? Or will there be timing problems probably? Any experience?

It works very well normally, just give it a try. Most often the network is the problem if there are issues, but 50 LEDs should work just fine!

Testing an coreELEC (9.2.1) now. What would you recommend, Hyperion or Hyperio.NG ?

I uninstalled HyperionNG and installed hyperion. Still NO effects on my LED strip.

“device” :
“name” : “coreELEC”,
“type” : “udpraw”,
“output” : “”,
“rate” : 1000000,
“maxpacket” : 1450,
“protocol” : 0,
“colorOrder” : “rgb”

What should a config look like? Any hint?
What is the options for WLED? And where to apply? “Receive UDP Realtime” ?

Use, the addon in coreelec ins the NG version too.

Any config examples? That would be helpfull.

Use the website for hyperion to change config, the ip and port 19446 should be right with udpraw.
And be sure wled device is turned on, it wont work turned off.

I have it running like that without any problems.

ok thanks mate. and what is the config in WLED? Anything that has to be configured to work?

No, the default should work out of the box.
Be sure your led count in hyperion is the same or less then the wled device.
Also set a layout, the total count in layout has to match the led controller.

Here is my example what I run.